]> git.pld-linux.org Git - packages/perl-CGI-Safe.git/blob - perl-CGI-Safe.spec
use generic url
[packages/perl-CGI-Safe.git] / perl-CGI-Safe.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    CGI
6 %define         pnam    Safe
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        CGI::Safe - safe method of using CGI.pm
9 Summary(pl.UTF-8):      CGI::Safe - bezpieczny sposób używania CGI.pm
10 Name:           perl-CGI-Safe
11 Version:        1.25
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  67e055249e96845adc8858bee0bba785
18 URL:            http://search.cpan.org/dist/CGI-Safe/
19 %{?with_tests:BuildRequires:    perl-CGI >= 2.20}
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 Requires:       perl-CGI >= 2.20
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module makes running the CGI environment safer by eliminating
28 dangerous %%ENV variables and presetting certain CGI.pm globals (such
29 as disabling uploads by default and limiting POST data size).
30
31 %description -l pl.UTF-8
32 Ten moduł czyni uruchamianie środowiska CGI bezpieczniejszym poprzez
33 usuwanie niebezpiecznych zmiennych z %%ENV i ustawianie kilku
34 zmiennych globalnych CGI.pm (takich jak domyślne wyłączenie
35 przysyłania danych czy ograniczenie rozmiaru danych POST).
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/CGI/Safe.pm
61 %{_mandir}/man3/*
This page took 0.070538 seconds and 3 git commands to generate.