]> git.pld-linux.org Git - packages/perl-Authen-NTLM.git/blob - perl-Authen-NTLM.spec
- updated BRs
[packages/perl-Authen-NTLM.git] / perl-Authen-NTLM.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Authen
7 %define         pnam    NTLM
8 Summary:        Authen::NTLM - Perl extension for NTLM related computations
9 Summary(pl.UTF-8):      Authen::NTLM - rozszerzenie Perla o obliczenia oparte na NTLM
10 Name:           perl-Authen-NTLM
11 Version:        1.09
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
17 # Source0-md5:  da314ee94b14af2a2f39b6f2c0046e73
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  perl-Crypt-DES >= 2.03
21 BuildRequires:  perl-Digest-HMAC
22 BuildRequires:  perl-Digest-MD4 >= 1.1
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _noautoreq      'perl(Crypt::DES_PP)' 'perl(Digest::Perl::MD4)'
27
28 %description
29 The NTLM (Windows NT LAN Manager) authentication scheme is the
30 authentication algorithm used by Microsoft.
31
32 NTLM authentication scheme is used in DCOM and HTTP environment. It is
33 used to authenticate DCE RPC packets in DCOM. It is also used to
34 authenticate HTTP packets to MS Web Proxy or MS Web Server.
35
36 As of this version, NTLM module only provides the client side
37 functions to calculate NT response and LM response.
38
39 %description -l pl.UTF-8
40 Schemat autentykacji NTLM (Windows NT LAN Manager) jest algorytmem
41 autentykacji używanym przez Microsoft.
42
43 Schemat autentykacji NTLM jest wykorzystywany w środowiskach DCOM i
44 HTTP. W DCOM służy do autentykacji pakietów DCE RPC. W HTTP jest
45 wykorzystywany do autentykacji pakietów HTTP przez MS Web Proxy i MS
46 Web Server.
47
48 Aktualna wersja modułu NTLM zawiera jedynie wsparcie dla funkcji
49 obliczających odpowiedzi NT i LM po stronie klienta.
50
51 %prep
52 %setup -q -n %{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %{perl_vendorlib}/Authen/NTLM.pm
73 %{perl_vendorlib}/Authen/NTLM
74 %{_mandir}/man3/*
This page took 0.098523 seconds and 3 git commands to generate.