]> git.pld-linux.org Git - packages/perl-Authen-NTLM.git/blob - perl-Authen-NTLM.spec
12912ef2468273dc46d134ebc6df9b3b5376b6d1
[packages/perl-Authen-NTLM.git] / perl-Authen-NTLM.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Authen
7 %define         pnam    NTLM
8 Summary:        Authen::NTLM - Perl extension for NTLM related computations
9 Summary(pl.UTF-8):      Authen::NTLM - rozszerzenie Perla o obliczenia oparte na NTLM
10 Name:           perl-Authen-NTLM
11 Version:        1.09
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
17 # Source0-md5:  da314ee94b14af2a2f39b6f2c0046e73
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  perl-Crypt-DES >= 2.03
21 BuildRequires:  perl-Digest-MD4 >= 1.1
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _noautoreq      'perl(Crypt::DES_PP)' 'perl(Digest::Perl::MD4)'
26
27 %description
28 The NTLM (Windows NT LAN Manager) authentication scheme is the
29 authentication algorithm used by Microsoft.
30
31 NTLM authentication scheme is used in DCOM and HTTP environment. It is
32 used to authenticate DCE RPC packets in DCOM. It is also used to
33 authenticate HTTP packets to MS Web Proxy or MS Web Server.
34
35 As of this version, NTLM module only provides the client side
36 functions to calculate NT response and LM response.
37
38 %description -l pl.UTF-8
39 Schemat autentykacji NTLM (Windows NT LAN Manager) jest algorytmem
40 autentykacji używanym przez Microsoft.
41
42 Schemat autentykacji NTLM jest wykorzystywany w środowiskach DCOM i
43 HTTP. W DCOM służy do autentykacji pakietów DCE RPC. W HTTP jest
44 wykorzystywany do autentykacji pakietów HTTP przez MS Web Proxy i MS
45 Web Server.
46
47 Aktualna wersja modułu NTLM zawiera jedynie wsparcie dla funkcji
48 obliczających odpowiedzi NT i LM po stronie klienta.
49
50 %prep
51 %setup -q -n %{pnam}-%{version}
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %{perl_vendorlib}/Authen/NTLM.pm
72 %{perl_vendorlib}/Authen/NTLM
73 %{_mandir}/man3/*
This page took 0.058741 seconds and 2 git commands to generate.