]> git.pld-linux.org Git - packages/perl-Audio-Play-MPG123.git/blob - perl-Audio-Play-MPG123.spec
cc1395aa1c99908f29388a6579cb597f995f035c
[packages/perl-Audio-Play-MPG123.git] / perl-Audio-Play-MPG123.spec
1 #
2 # TODO: add subpackage with included version of mpg123, or add patches to
3 #       mpg123 package (this module works better with modified version)
4 #
5 # Conditional build:
6 %bcond_without  tests   # do not perform "make test"
7
8 %define         pdir    Audio
9 %define         pnam    Play-MPG123
10 %include        /usr/lib/rpm/macros.perl
11 Summary:        Audio::Play::MPG123 Perl module - a frontend to mpg123
12 Summary(pl.UTF-8):      Moduł Perla Audio::Play::MPG123 - frontend do mpg123
13 Name:           perl-Audio-Play-MPG123
14 Version:        0.63
15 Release:        2
16 License:        GPL v1 or Artistic
17 Group:          Development/Languages/Perl
18 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
19 # Source0-md5:  bd5134e4a7b5a537a921e464dc264e5f
20 URL:            http://search.cpan.org/dist/Audio-Play-MPG123/
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 Requires:       mpg123 >= 0.59r
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This is a frontend to the mpg123 player. It works by starting an
29 external mpg123 process with the `-R' option and feeding commands to
30 it.
31
32 %description -l pl.UTF-8
33 To jest frontend do odtwarzacza mpg123. Funkcjonuje poprzez
34 uruchomienie zewnętrznego procesu mpg123 z opcją -R i karmienie go
35 poleceniami.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc COPYING Changes README
59 %attr(755,root,root) %{_bindir}/mpg123sh
60 %dir %{perl_vendorlib}/Audio/Play
61 %{perl_vendorlib}/Audio/Play/MPG123.pm
62 %{_mandir}/man3/*
This page took 0.052949 seconds and 2 git commands to generate.