]> git.pld-linux.org Git - packages/perl-Audio-OSS.git/blob - perl-Audio-OSS.spec
use generic url
[packages/perl-Audio-OSS.git] / perl-Audio-OSS.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Audio
6 %define         pnam    OSS
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Audio::OSS Perl module - interface to Open Sound System
9 Summary(pl.UTF-8):      Moduł Perla Audio::OSS - interfejs do Open Sound System
10 Name:           perl-Audio-OSS
11 Version:        0.0501
12 Release:        5
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8c77167acea908501c243be198149efb
18 URL:            http://search.cpan.org/dist/Audio-OSS/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Provides:       perl(Audio::OSS::Constants)
22 # it uses C code only at build time - built package doesn't contain any binaries
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module provides a pure-Perl, no-nonsense, filehandle-based
28 interface to the Open Sound System. Audio::DSP is fine for simple,
29 blocking audio I/O, but it doesn't hold up when you want to do
30 something more complicated. That is, it doesn't expose the features of
31 the audio device interface that are required to do things like
32 non-blocking audio, real-time control of playback, querying the
33 capabilities of the audio device, finding the supported sampling
34 rates, etc. Audio::OSS provides a procedural interface based around
35 filehandles opened on the audio device (usually /dev/dsp* for PCM
36 audio). It also defines constants for various ioctl calls and other
37 things based on the OSS system header files, so you don't have to rely
38 on .ph files that may or may be correct or even present on your
39 system.
40
41 %description -l pl.UTF-8
42 Ten moduł udostępnia czysto perlowy, logiczny, oparty na uchwytach
43 plików interfejs do systemu dźwięku Open Sound. Audio::DSP jest dobry
44 do prostego, blokującego odtwarzania/nagrywania dźwięku, ale nie
45 wystarcza, jeśli trzeba zrobić coś bardziej skomplikowanego. To znaczy
46 nie udostępnia możliwości interfejsu OSS potrzebnych do rzeczy takich
47 jak nie blokujący dźwięk, kontrola odtwarzania w czasie rzeczywistym,
48 odczytywanie możliwości urządzenia dźwiękowego, sprawdzanie
49 obsługiwanych częstotliwości próbkowania itp. Moduł Audio::OSS
50 udostępnia proceduralny interfejs oparty na uchwytach plików
51 związanych z urządzeniem dźwiękowym (zazwyczaj /dev/dsp* dla dźwięku
52 PCM). Moduł także definiuje stałe dla różnych wywołań ioctl oraz
53 innych rzeczy związanych z plikami nagłówkowymi OSS, więc nie trzeba
54 polegać na plikach .ph.
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 %build
60 %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62 %{__make}
63
64 %{?with_tests:%{__make} test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Changes README
78 %{perl_vendorlib}/Audio/OSS.pm
79 %{perl_vendorlib}/Audio/OSS
80 %{_mandir}/man3/*
This page took 0.074219 seconds and 3 git commands to generate.