]> git.pld-linux.org Git - packages/perl-Audio-Mixer.git/blob - perl-Audio-Mixer.spec
465eeb3c222ccf09eb719a0e47a2b6fffe32ad10
[packages/perl-Audio-Mixer.git] / perl-Audio-Mixer.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (opens /dev/mixer)
4
5 %define         pdir    Audio
6 %define         pnam    Mixer
7 Summary:        Audio::Mixer - Perl extension for sound mixer control
8 Summary(pl.UTF-8):      Audio::Mixer - rozszerzenie Perla do sterowania mikserem dźwięku
9 Name:           perl-Audio-Mixer
10 Version:        0.7
11 Release:        15
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  5aaa808a4852ed68f952705172ece2a8
17 URL:            http://search.cpan.org/dist/Audio-Mixer/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This is just a very simple Perl interface which allows to set various
24 sound mixer parameters. The most important probably 'vol' (volume).
25 The list of all mixer parameters can be obtained using
26 get_mixer_params() function.
27
28 %description -l pl.UTF-8
29 To jest bardzo prosty perlowy interfejs, pozwalający na ustawianie
30 różnych parametrów miksera dźwięku. Prawdopodobnie najważniejszym jest
31 'vol' (głośność). Listę wszystkich parametrów miksera można odczytać
32 funkcją get_mixer_params().
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %attr(755,root,root) %{perl_vendorarch}/Audio/volume.pl
59 %{perl_vendorarch}/Audio/Mixer.pm
60 %dir %{perl_vendorarch}/auto/Audio/Mixer
61 %{perl_vendorarch}/auto/Audio/Mixer/autosplit.ix
62 %attr(755,root,root) %{perl_vendorarch}/auto/Audio/Mixer/*.so
63 %{_mandir}/man3/*
This page took 0.121251 seconds and 2 git commands to generate.