]> git.pld-linux.org Git - packages/perl-Audio-Mad.git/blob - perl-Audio-Mad.spec
a0c35d7eebf3ea7b75c7c67f4c82f2505435bbf3
[packages/perl-Audio-Mad.git] / perl-Audio-Mad.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Audio
7 %define         pnam    Mad
8 Summary:        Audio::Mad Perl module - interface to the mad MPEG decoder library
9 Summary(pl.UTF-8):      Moduł Perla Audio::Mad - interfejs do biblioteki dekodera MPEG mad
10 Name:           perl-Audio-Mad
11 Version:        0.6
12 Release:        1
13 License:        GPL v2
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ede73e114efea0956f8abdb4072fa0bf
17 BuildRequires:  libmad-devel
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Audio::Mad is a Perl module designed to provide an abstract interface
24 to the low level mad mpeg decoder library. Interfaces for mad_stream,
25 mad_frame, mad_synth, and mad_timer_t are provided. Two addon
26 interfaces Mad::Resample and Mad::Dither provide methods for
27 manipulating raw mad_fixed_t data into usable strings.
28
29 %description -l pl.UTF-8
30 Audio::Mad to moduł Perla stworzony by udostępnić abstrakcyjny
31 interfejs do niskopoziomowej biblioteki dekodera MPEG - mad. Dostarcza
32 interfejsy do mad_stream, mad_frame, mad_synth i mad_timer_t. Dwa
33 dodatkowe interfejsy Mad::Resample i Mad::Dither udostępniają metody
34 do przekształcania surowych danych mad_fixed_t na użyteczne ciągi.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/Audio/Mad.pm
61 %{perl_vendorarch}/Audio/Mad
62 %dir %{perl_vendorarch}/auto/Audio/Mad
63 %attr(755,root,root) %{perl_vendorarch}/auto/Audio/Mad/*.so
64 %{_mandir}/man3/*
This page took 0.056337 seconds and 2 git commands to generate.