]> git.pld-linux.org Git - packages/perl-Audio-MPEG.git/blob - perl-Audio-MPEG.spec
e906e29560f684844dd59166e21c06997d2c55bc
[packages/perl-Audio-MPEG.git] / perl-Audio-MPEG.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do perform "make test"
4 #               (fails probably because of libmad version different from reference one)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    Audio
8 %define         pnam    MPEG
9 Summary:        Audio::MPEG Perl module - encoding and decoding of MPEG Audio
10 Summary(pl.UTF-8):      Moduł Perla Audio::MPEG - kodowanie i dekodowanie dźwięku MPEG
11 Name:           perl-Audio-MPEG
12 Version:        0.04
13 Release:        5
14 License:        GPL v2+
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  9c5b09cf06c934a001b81c05f786a295
18 Patch0:         %{name}-lame-fix.patch
19 Patch1:         %{name}-build.patch
20 BuildRequires:  lame-libs-devel
21 BuildRequires:  libmad-devel
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module will allow a Perl program to verify an MP3 file (fixed and
28 variable bitrate), decode it into a high-resolution (24 bit) PCM
29 stream, apply filtering effects to the data (stereo->mono, fade
30 in/out, equalizer), transform that stream into an audio stream (WAV,
31 Sun AU, integer PCM, floating point PCM), and finally encode a PCM
32 stream as an MP3.
33
34 %description -l pl.UTF-8
35 Ten moduł umożliwia programom w Perlu weryfikację plików MP3 (o
36 zmiennej i stałej prędkości strumienia), dekodowanie ich do strumienia
37 PCM o dużej rozdzielczości (24 bity), przepuszczanie przez filtry
38 efektów (stereo->moni, wchodzenie/wyciszanie, equalizer),
39 przekształcanie tego strumienia na strumień dźwiękowy (WAV, Sun AU,
40 całkowitoliczbowy PCM, zmiennoprzecinkowy PCM) i w końcu kodowanie
41 strumieni PCM do MP3.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45 %patch0 -p1
46 %patch1 -p1
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make} \
52         CC="%{__cc}" \
53         OPTIMIZE="%{rpmcflags}"
54
55 # "encode" tests and half of "wave" test fail
56 # please, check it again
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %{perl_vendorarch}/Audio/MPEG.pm
72 %dir %{perl_vendorarch}/auto/Audio/MPEG
73 %attr(755,root,root) %{perl_vendorarch}/auto/Audio/MPEG/*.so
74 %{_mandir}/man3/*
This page took 0.050304 seconds and 2 git commands to generate.