]> git.pld-linux.org Git - packages/perl-Attribute-Protected.git/blob - perl-Attribute-Protected.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Attribute-Protected.git] / perl-Attribute-Protected.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Attribute
6 %define         pnam    Protected
7 Summary:        Attribute::Protected - implementing proctected methods with attributes
8 Summary(pl.UTF-8):      Attribute::Protected - implementacja metod i atrybutów chronionych
9 Name:           perl-Attribute-Protected
10 Version:        0.03
11 Release:        4
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  797463820a6149feadf1aa52fae2673a
17 URL:            http://search.cpan.org/dist/Attribute-Protected/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Attribute::Protected implements something like public / private /
25 protected methods in C++ or Java.
26
27 %description -l pl.UTF-8
28 Attribute::Protected implementuje coś na kształt publicznych /
29 prywatnych / chronionych metod w C++ i Javie.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37 %{__make}
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %{perl_vendorlib}/%{pdir}/%{pnam}.pm
53 %{_mandir}/man3/*.3pm*
This page took 0.416853 seconds and 3 git commands to generate.