]> git.pld-linux.org Git - packages/perl-Attribute-Protected.git/blob - perl-Attribute-Protected.spec
use generic url
[packages/perl-Attribute-Protected.git] / perl-Attribute-Protected.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Attribute
6 %define         pnam    Protected
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Attribute::Protected - implementing proctected methods with attributes
9 Summary(pl.UTF-8):      Attribute::Protected - implementacja metod i atrybutów chronionych
10 Name:           perl-Attribute-Protected
11 Version:        0.03
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  797463820a6149feadf1aa52fae2673a
18 URL:            http://search.cpan.org/dist/Attribute-Protected/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Attribute::Protected implements something like public / private /
26 protected methods in C++ or Java.
27
28 %description -l pl.UTF-8
29 Attribute::Protected implementuje coś na kształt publicznych /
30 prywatnych / chronionych metod w C++ i Javie.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %{perl_vendorlib}/%{pdir}/%{pnam}.pm
54 %{_mandir}/man3/*.3pm*
This page took 0.112939 seconds and 3 git commands to generate.