]> git.pld-linux.org Git - packages/perl-Attribute-Persistent.git/blob - perl-Attribute-Persistent.spec
- should be ready for perl-5.8.0; release++
[packages/perl-Attribute-Persistent.git] / perl-Attribute-Persistent.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Attribute
7 %define pnam    Persistent
8 Summary:        Attribute::Persistent - Really lazy persistence
9 Summary(pl):    Attribute::Persistent - bardzo leniwe zachowywanie atrybutów
10 Name:           perl-Attribute-Persistent
11 Version:        1.0
12 Release:        3
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 BuildRequires:  perl >= 5.6
17 %if %{?_without_tests:0}%{!?_without_tests:1}
18 BuildRequires:  perl-Attribute-Handlers-Prospective
19 BuildRequires:  perl-Digest-MD5
20 BuildRequires:  perl-MLDBM
21 %endif
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module provides a way of abstracting away persistence of array
28 and hash variables.
29
30 It's useful for quick hacks when you don't care about pulling in the
31 right DBM library and calling tie and so on. Its job is to reduce fuss
32 for the lazy programmer at the cost of flexibility.
33
34 %description -l pl
35 Ten modu³ udostêpnia metodê na wyabstrahowanie zachowywania zmiennych
36 tablicowych i haszy. Jest przydatnych do szybkich hacków, kiedy nie
37 dba siê o wyci±ganie w³a¶ciwej biblioteki DBM, wywo³ywanie jej
38 dowi±zañ itd. Zadaniem modu³u jest zredukowanie zamieszania dla
39 leniwego programisty kosztem elastyczno¶ci.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor 
47 %{__make}
48
49 %{!?_without_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Change*
62 %{perl_vendorlib}/%{pdir}/*.pm
63 %{_mandir}/man3/*
This page took 0.068394 seconds and 4 git commands to generate.