]> git.pld-linux.org Git - packages/perl-Attribute-Persistent.git/blob - perl-Attribute-Persistent.spec
- formatting
[packages/perl-Attribute-Persistent.git] / perl-Attribute-Persistent.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Attribute
7 %define         pnam    Persistent
8 Summary:        Attribute::Persistent - really lazy persistence
9 Summary(pl):    Attribute::Persistent - bardzo leniwe zachowywanie atrybutów
10 Name:           perl-Attribute-Persistent
11 Version:        1.0
12 Release:        4
13 License:        GPL or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  04253a2788a686d26cb2b428a92071b1
17 BuildRequires:  perl-devel >= 1:5.8.0
18 %if %{with tests}
19 BuildRequires:  perl-Attribute-Handlers-Prospective
20 BuildRequires:  perl-Digest-MD5
21 BuildRequires:  perl-MLDBM
22 %endif
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module provides a way of abstracting away persistence of array
29 and hash variables.
30
31 It's useful for quick hacks when you don't care about pulling in the
32 right DBM library and calling tie and so on. Its job is to reduce fuss
33 for the lazy programmer at the cost of flexibility.
34
35 %description -l pl
36 Ten modu³ udostêpnia metodê na wyabstrahowanie zachowywania zmiennych
37 tablicowych i haszy. Jest przydatnych do szybkich hacków, kiedy nie
38 dba siê o wyci±ganie w³a¶ciwej biblioteki DBM, wywo³ywanie jej
39 dowi±zañ itd. Zadaniem modu³u jest zredukowanie zamieszania dla
40 leniwego programisty kosztem elastyczno¶ci.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Change*
64 %{perl_vendorlib}/%{pdir}/*.pm
65 %{_mandir}/man3/*
This page took 0.026531 seconds and 4 git commands to generate.