]> git.pld-linux.org Git - packages/perl-Astro-FITS-Header.git/blob - perl-Astro-FITS-Header.spec
use generic url
[packages/perl-Astro-FITS-Header.git] / perl-Astro-FITS-Header.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_with     ndf     # build package with NDF support
5 %bcond_with     gsd     # build package with GSD support
6
7 %define         pdir    Astro
8 %define         pnam    FITS-Header
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Astro::FITS::Header Perl module - a FITS header
11 Summary(pl.UTF-8):      Moduł Perla Astro::FITS::Header - nagłówek FITS
12 Name:           perl-Astro-FITS-Header
13 Version:        3.07
14 Release:        2
15 License:        GPL v2+
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  3a9795ecc74269419340e900018a5840
19 URL:            http://search.cpan.org/dist/Astro-FITS-Header/
20 %if %{with tests}
21 BuildRequires:  perl-Astro-FITS-CFITSIO >= 1.01
22 %endif
23 BuildRequires:  perl-devel >= 1:5.8.2
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 Requires:       perl-base >= 5.8.2
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Astro::FITS::Header and associated sub-classes are tools for reading,
31 modifying and then writing out FITS standard header blocks to FITS and
32 NDF files.
33
34 %description -l pl.UTF-8
35 Astro::FITS::Header i stowarzyszone z nim podklasy stanowią narzędzie
36 służące do odczytu bloków nagłówków zgodnych ze standardem FITS w
37 plikach FITS i NDF, a także do modyfikacji i zapisu tych bloków.
38
39 %package CFITSIO
40 Summary:        Astro::FITS::Header::CFITSIO - manipulates FITS headers from a FITS file
41 Summary(pl.UTF-8):      Astro::FITS::Header::CFITSIO - manipulowanie nagłówkami FITS pliku FITS
42 Group:          Development/Languages/Perl
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       perl-Astro-FITS-CFITSIO >= 1.01
45
46 %description CFITSIO
47 Astro::FITS::Header::CFITSIO module makes use of the
48 Astro::FITS::CFITSIO module to read and write directly to a FITS HDU.
49
50 %description CFITSIO -l pl.UTF-8
51 Moduł Astro::FITS::Header::CFITSIO dokonuje bezpośredniego odczytu i
52 zapisu FITS HDU za pomocą modułu Astro::FITS::CFITSIO.
53
54 %package NDF
55 Summary:        Astro::FITS::Header::NDF - manipulate FITS headers from NDF files
56 Summary(pl.UTF-8):      Astro::FITS::Header::NDF - manipulowanie nagłówkami FITS plików NDF
57 Group:          Development/Languages/Perl
58 # only for install dirs ?
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       perl-NDF >= 1.42
61
62 %description NDF
63 Astro::FITS::Header::NDF module makes use of the Starlink NDF module
64 to read and write to and NDF FITS extension or to a ".HEADER" block in
65 an HDS container file.
66
67 %description NDF -l pl.UTF-8
68 Moduł Astro::FITS::Header::NDF odczytuje i zapisuje rozszerzenie NDF
69 FITS lub blok ".HEADER" pliku pojemnika HDS za pomocą modułu Starlink
70 NDF.
71
72 %package GSD
73 Summary:        Astro::FITS::Header::GSD - manipulate FITS headers from GSD files
74 Summary(pl.UTF-8):      Astro::FITS::Header::GSD - manipulowanie nagłówkami FITS plików GSD
75 Group:          Development/Languages/Perl
76 Requires:       %{name} = %{version}-%{release}
77
78 %description GSD
79 Astro::FITS::Header::GSD module makes use of the Starlink GSD module
80 to read from a GSD header.
81
82 %description GSD -l pl.UTF-8
83 Moduł Astro::FITS::Header::GSD odczytuje nagłówek GSD za pomocą modułu
84 Starlink GSD.
85
86 %prep
87 %setup -q -n %{pdir}-%{pnam}-%{version}
88
89 %build
90 %{__perl} Build.PL \
91         installdirs=vendor
92 ./Build
93
94 %{?with_tests:./Build test}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 ./Build install \
100         prefix=%{_prefix} \
101         destdir=$RPM_BUILD_ROOT
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %files
107 %defattr(644,root,root,755)
108 %doc README TODO
109 %dir %{perl_vendorlib}/Astro/FITS
110 %{perl_vendorlib}/Astro/FITS/Header.pm
111 %dir %{perl_vendorlib}/Astro/FITS/Header
112 %{perl_vendorlib}/Astro/FITS/Header/Item*
113 %{perl_vendorlib}/Astro/FITS/Header/AST.pm
114 %{_mandir}/man3/Astro::FITS::Header.*
115 %{_mandir}/man3/Astro::FITS::Header::Item*
116 %{_mandir}/man3/Astro::FITS::Header::AST.3pm*
117
118 %files CFITSIO
119 %defattr(644,root,root,755)
120 %{perl_vendorlib}/Astro/FITS/Header/CFITSIO.pm
121 %{_mandir}/man3/*CFITSIO*
122
123 %if %{with ndf}
124 %files NDF
125 %defattr(644,root,root,755)
126 %{perl_vendorlib}/Astro/FITS/Header/NDF.pm
127 %{_mandir}/man3/*NDF*
128 %endif
129
130 %if %{with gsd}
131 %files GSD
132 %defattr(644,root,root,755)
133 %{perl_vendorlib}/Astro/FITS/Header/GSD.pm
134 %{_mandir}/man3/*GSD*
135 %endif
This page took 0.085266 seconds and 3 git commands to generate.