]> git.pld-linux.org Git - packages/perl-Astro-FITS-Header.git/blob - perl-Astro-FITS-Header.spec
7eaeafbef6a157a2f8918afabfb8961ce133c007
[packages/perl-Astro-FITS-Header.git] / perl-Astro-FITS-Header.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_with     ndf     # build package with NDF support
5 %bcond_with     gsd     # build package with GSD support
6 #
7 %include        /usr/lib/rpm/macros.perl
8 %define         pdir    Astro
9 %define         pnam    FITS-Header
10 Summary:        Astro::FITS::Header Perl module - a FITS header
11 Summary(pl.UTF-8):      Moduł Perla Astro::FITS::Header - nagłówek FITS
12 Name:           perl-Astro-FITS-Header
13 Version:        3.07
14 Release:        2
15 License:        GPL v2+
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  3a9795ecc74269419340e900018a5840
19 %if %{with tests}
20 BuildRequires:  perl-Astro-FITS-CFITSIO >= 1.01
21 %endif
22 BuildRequires:  perl-devel >= 1:5.8.2
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 Requires:       perl-base >= 5.8.2
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Astro::FITS::Header and associated sub-classes are tools for reading,
30 modifying and then writing out FITS standard header blocks to FITS and
31 NDF files.
32
33 %description -l pl.UTF-8
34 Astro::FITS::Header i stowarzyszone z nim podklasy stanowią narzędzie
35 służące do odczytu bloków nagłówków zgodnych ze standardem FITS w
36 plikach FITS i NDF, a także do modyfikacji i zapisu tych bloków.
37
38 %package CFITSIO
39 Summary:        Astro::FITS::Header::CFITSIO - manipulates FITS headers from a FITS file
40 Summary(pl.UTF-8):      Astro::FITS::Header::CFITSIO - manipulowanie nagłówkami FITS pliku FITS
41 Group:          Development/Languages/Perl
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       perl-Astro-FITS-CFITSIO >= 1.01
44
45 %description CFITSIO
46 Astro::FITS::Header::CFITSIO module makes use of the
47 Astro::FITS::CFITSIO module to read and write directly to a FITS HDU.
48
49 %description CFITSIO -l pl.UTF-8
50 Moduł Astro::FITS::Header::CFITSIO dokonuje bezpośredniego odczytu i
51 zapisu FITS HDU za pomocą modułu Astro::FITS::CFITSIO.
52
53 %package NDF
54 Summary:        Astro::FITS::Header::NDF - manipulate FITS headers from NDF files
55 Summary(pl.UTF-8):      Astro::FITS::Header::NDF - manipulowanie nagłówkami FITS plików NDF
56 Group:          Development/Languages/Perl
57 # only for install dirs ?
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       perl-NDF >= 1.42
60
61 %description NDF
62 Astro::FITS::Header::NDF module makes use of the Starlink NDF module
63 to read and write to and NDF FITS extension or to a ".HEADER" block in
64 an HDS container file.
65
66 %description NDF -l pl.UTF-8
67 Moduł Astro::FITS::Header::NDF odczytuje i zapisuje rozszerzenie NDF
68 FITS lub blok ".HEADER" pliku pojemnika HDS za pomocą modułu Starlink
69 NDF.
70
71 %package GSD
72 Summary:        Astro::FITS::Header::GSD - manipulate FITS headers from GSD files
73 Summary(pl.UTF-8):      Astro::FITS::Header::GSD - manipulowanie nagłówkami FITS plików GSD
74 Group:          Development/Languages/Perl
75 Requires:       %{name} = %{version}-%{release}
76
77 %description GSD
78 Astro::FITS::Header::GSD module makes use of the Starlink GSD module
79 to read from a GSD header.
80
81 %description GSD -l pl.UTF-8
82 Moduł Astro::FITS::Header::GSD odczytuje nagłówek GSD za pomocą modułu
83 Starlink GSD.
84
85 %prep
86 %setup -q -n %{pdir}-%{pnam}-%{version}
87
88 %build
89 %{__perl} Build.PL \
90         installdirs=vendor
91 ./Build
92
93 %{?with_tests:./Build test}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 ./Build install \
99         prefix=%{_prefix} \
100         destdir=$RPM_BUILD_ROOT
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(644,root,root,755)
107 %doc README TODO
108 %dir %{perl_vendorlib}/Astro/FITS
109 %{perl_vendorlib}/Astro/FITS/Header.pm
110 %dir %{perl_vendorlib}/Astro/FITS/Header
111 %{perl_vendorlib}/Astro/FITS/Header/Item*
112 %{perl_vendorlib}/Astro/FITS/Header/AST.pm
113 %{_mandir}/man3/Astro::FITS::Header.*
114 %{_mandir}/man3/Astro::FITS::Header::Item*
115 %{_mandir}/man3/Astro::FITS::Header::AST.3pm*
116
117 %files CFITSIO
118 %defattr(644,root,root,755)
119 %{perl_vendorlib}/Astro/FITS/Header/CFITSIO.pm
120 %{_mandir}/man3/*CFITSIO*
121
122 %if %{with ndf}
123 %files NDF
124 %defattr(644,root,root,755)
125 %{perl_vendorlib}/Astro/FITS/Header/NDF.pm
126 %{_mandir}/man3/*NDF*
127 %endif
128
129 %if %{with gsd}
130 %files GSD
131 %defattr(644,root,root,755)
132 %{perl_vendorlib}/Astro/FITS/Header/GSD.pm
133 %{_mandir}/man3/*GSD*
134 %endif
This page took 0.075938 seconds and 2 git commands to generate.