]> git.pld-linux.org Git - packages/perl-Array-IntSpan.git/blob - perl-Array-IntSpan.spec
use generic url
[packages/perl-Array-IntSpan.git] / perl-Array-IntSpan.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Array
6 %define         pnam    IntSpan
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Array::IntSpan - a module for handling arrays using IntSpan techniques
9 Summary(pl.UTF-8):      Array::IntSpan - moduł do obsługi tablic z użyciem techniki IntSpan
10 Name:           perl-Array-IntSpan
11 Version:        2.002
12 Release:        1
13 # http://www.ActiveState.com/corporate/artistic_license.htm or
14 # the license that comes with your perl distribution.
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  a21691f17c714ee82ee6cdd14f2b899c
19 URL:            http://search.cpan.org/dist/Array-IntSpan/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Array::IntSpan brings the speed advantages of Set::IntSpan (written by
27 Steven McDougall) to arrays. Uses include manipulating grades, routing
28 tables, or any other situation where you have mutually exclusive
29 ranges of integers that map to given values (or objects). This version
30 of Array::IntSpan is able to consolidate ranges by comparing adjacent
31 values.
32
33 %description -l pl.UTF-8
34 Array::IntSpan przenosi zyski szybkościowe Set::IntSpan do tablic.
35 Może być używany do manipulacji rangami, tablicami routingu lub w
36 każdej innej sytuacji gdzie są rozłączne zakresy liczb całkowitych,
37 które mają przypisane do nich wartości lub obiekty. Ta wersja
38 Array::IntSpan jest w stanie konsolidować zakresy poprzez porównanie
39 sąsiadujących wartości.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc ChangeLog README
64 %{perl_vendorlib}/Array/IntSpan.pm
65 %dir %{perl_vendorlib}/Array/IntSpan
66 %{perl_vendorlib}/Array/IntSpan/*.pm
67 %{_mandir}/man3/*
This page took 0.566598 seconds and 3 git commands to generate.