]> git.pld-linux.org Git - packages/perl-App-Nopaste.git/blob - perl-App-Nopaste.spec
89fc44fa9f593ac6593c6b32bbe58122cc183e37
[packages/perl-App-Nopaste.git] / perl-App-Nopaste.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 %define         pdir    App
6 %define         pnam    Nopaste
7 Summary:        App::Nopaste - easy access to any pastebin
8 Summary(pl.UTF-8):      App::Nopaste - łatwy dostęp do dowolnego pastebina
9 Name:           perl-App-Nopaste
10 Version:        1.013
11 Release:        1
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/App/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a32fe4ee8f8887dc9064c221eaf7372f
17 URL:            https://metacpan.org/dist/App-Nopaste
18 BuildRequires:  perl-CPAN-Meta-Requirements >= 2.120_620
19 BuildRequires:  perl-ExtUtils-MakeMaker
20 BuildRequires:  perl-devel >= 1:5.8.3
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 #BuildRequires: perl(Browser::Open)
24 #BuildRequires: perl(Clipboard)
25 #BuildRequires: perl(Config::GitLike) >= 0.00
26 #BuildRequires: perl(WWW::Pastebin::PastebinCom::Create)
27 BuildRequires:  perl-Class-Load
28 BuildRequires:  perl-Getopt-Long-Descriptive
29 BuildRequires:  perl-JSON-MaybeXS
30 BuildRequires:  perl-Module-Pluggable
31 BuildRequires:  perl-Module-Runtime
32 BuildRequires:  perl-Path-Tiny
33 BuildRequires:  perl-Test-Deep
34 BuildRequires:  perl-Test-Fatal
35 BuildRequires:  perl-Test-Simple >= 0.88
36 BuildRequires:  perl-URI
37 BuildRequires:  perl-WWW-Mechanize
38 BuildRequires:  perl-libwww
39 BuildRequires:  perl-namespace-clean >= 0.19
40 %endif
41 BuildArch:      noarch
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Pastebins (also known as nopaste sites) let you post text, usually
46 code, for public viewing. They're used a lot in IRC channels to show
47 code that would normally be too long to give directly in the channel
48 (hence the name nopaste).
49
50 %description -l pl.UTF-8
51 Pastebiny (znane też jako strony nopaste) pozwalają przesyłać tekst
52 (zwykle kod) do publicznego wglądu. Są używane często na kanałach IRC,
53 aby pokazywać kod, który zwykle byłby zbyt długi do wysyłania
54 bezpośrednio na kanał (stąd nazwa nopaste).
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 %build
60 echo y | %{__perl} Makefile.PL --skipdeps \
61         INSTALLDIRS=vendor
62 %{__make}
63
64 %{?with_tests:%{__make} test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} pure_install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Changes README
78 %{perl_vendorlib}/App/Nopaste.pm
79 %{perl_vendorlib}/App/Nopaste
80 %{_mandir}/man3/App::Nopaste*.3pm*
81
82 #files -n nopaste
83 %attr(755,root,root) %{_bindir}/nopaste
84 %{_mandir}/man1/nopaste.1p*
This page took 0.057609 seconds and 2 git commands to generate.