]> git.pld-linux.org Git - packages/perl-App-Nopaste.git/blob - perl-App-Nopaste.spec
- up to 1.013
[packages/perl-App-Nopaste.git] / perl-App-Nopaste.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    App
6 %define         pnam    Nopaste
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        App::Nopaste - easy access to any pastebin
9 Name:           perl-App-Nopaste
10 Version:        1.013
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/App/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a32fe4ee8f8887dc9064c221eaf7372f
17 URL:            http://search.cpan.org/dist/App-Nopaste/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 #BuildRequires: perl(Browser::Open)
22 #BuildRequires: perl(Clipboard)
23 #BuildRequires: perl(Config::GitLike) >= 0.00
24 #BuildRequires: perl(WWW::Pastebin::PastebinCom::Create)
25 BuildRequires:  perl-Class-Load
26 BuildRequires:  perl-Moose >= 0.74
27 BuildRequires:  perl-MooseX-Getopt >= 0.17
28 BuildRequires:  perl-URI
29 BuildRequires:  perl-WWW-Mechanize
30 %endif
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Pastebins (also known as nopaste sites) let you post text, usually
36 code, for public viewing. They're used a lot in IRC channels to show
37 code that would normally be too long to give directly in the channel
38 (hence the name nopaste).
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 echo y | %{__perl} Makefile.PL --skipdeps \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes
62 %{perl_vendorlib}/App/*.pm
63 %{perl_vendorlib}/App/Nopaste
64 %{_mandir}/man3/*
65
66 #files -n nopaste
67 %attr(755,root,root) %{_bindir}/nopaste
68 %{_mandir}/man1/nopaste.1p*
This page took 0.067374 seconds and 3 git commands to generate.