]> git.pld-linux.org Git - packages/perl-Apache-SessionManager.git/blob - perl-Apache-SessionManager.spec
use generic url
[packages/perl-Apache-SessionManager.git] / perl-Apache-SessionManager.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4
5 %define         pdir    Apache
6 %define         pnam    SessionManager
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Apache::SessionManager - simple mod_perl extension to manage sessions
9 Summary(pl.UTF-8):      Apache::SessionManager - proste rozszerzenie mod_perla do obsługi sesji
10 Name:           perl-Apache-SessionManager
11 Version:        1.03
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  85b412074edde465fcf291a1fef0e5e2
18 URL:            http://search.cpan.org/dist/Apache-SessionManager/
19 BuildRequires:  apache-mod_perl
20 BuildRequires:  perl-Apache-Session
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Apache::SessionManager is a mod_perl module that helps session
28 management of a web application. This simple module is a wrapper
29 around Apache::Session persistence framework for session data. It
30 creates a session object and makes it available to all other handlers
31 by putting in pnotes. In a mod_perl handler you can retrieve the
32 session object directly from pnotes with predefined key
33 'SESSION_MANAGER_HANDLE'.
34
35 %description -l pl.UTF-8
36 Apache::SessionManager to moduł do mod_perla pomagający w zarządzaniu
37 sesjami w aplikacjach WWW. Ten prosty moduł jest obudowaniem szkieletu
38 zachowywania danych sesji Apache::Session. Tworzy on obiekt sesji i
39 czyni go dostępnym dla wszystkich innych funkcji obsługujących poprzez
40 umieszcenie w pnotes. W obsłudze mod_perla można odczytywać obiekt
41 sesji bezpośrednio z pnotes przy pomocy predefiniowanego klucza
42 'SESSION_MANAGER_HANDLE'.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 perl Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Change* README
66 %{perl_vendorlib}/%{pdir}/*.pm
67 %{_mandir}/man3/*
This page took 0.077043 seconds and 3 git commands to generate.