]> git.pld-linux.org Git - packages/perl-Apache-Scoreboard.git/blob - perl-Apache-Scoreboard.spec
19507e8c3b50d41bfac7f87b67d4e612f48ff1ac
[packages/perl-Apache-Scoreboard.git] / perl-Apache-Scoreboard.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test". starts test httpd service
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Apache
7 %define         pnam    Scoreboard
8 Summary:        Apache::Scoreboard - Perl interface to the Apache scoreboard structure
9 Summary(pl.UTF-8):      Apache::Scoreboard - perlowy interfejs do struktury scoreboard Apache'a
10 Name:           perl-Apache-Scoreboard
11 Version:        2.09.2
12 Release:        3
13 License:        unknown
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  df133feb853c4ef743557e6621adcc3f
17 BuildRequires:  apache-mod_perl-devel
18 BuildRequires:  apr-devel >= 1:1.0
19 BuildRequires:  apr-util-devel >= 1:1.0
20 BuildRequires:  perl-Apache-Test
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  perl-mod_perl
23 %if %{with tests}
24 BuildRequires:  perl-Chart-PNGgraph
25 %endif
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Apache keeps track of server activity in a structure known as the
31 scoreboard. There is a slot in the scoreboard for each child server,
32 containing information such as status, access count, bytes served and
33 cpu time. This same information is used by mod_status to provide
34 current server statistics in a human readable form.
35
36 %description -l pl.UTF-8
37 Apache śledzi aktywność serwera w strukturze znanej jako scoreboard. W
38 scoreboard znajduje się slot dla każdego serwera potomnego,
39 zawierający informacje takie jak stan, liczba klientów, wysłanych
40 bajtów i zajęty czas procesora. Te same informacje są używane przez
41 mod_status do udostępniania aktualnych statystyk w postaci czytelnej
42 dla człowieka.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-2.09
46
47 %build
48 INC="-I/usr/include/apache $(apr-1-config --includes) $(apu-1-config --includes)"
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor \
51         INC="$INC"
52 cd Dummy
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor \
55         INC="$INC"
56 cd ..
57 %{__make} \
58         CC="%{__cc}" \
59         OPTIMIZE="%{rpmcflags}"
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 install -d $RPM_BUILD_ROOT%{_examplesdir}
69 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
71 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Apache/Scoreboard/.packlist
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes README
79 %{perl_vendorarch}/Apache/*.pm
80 %dir %{perl_vendorarch}/auto/Apache
81 %dir %{perl_vendorarch}/auto/Apache/Scoreboard
82 %attr(755,root,root) %{perl_vendorarch}/auto/Apache/Scoreboard/*.so
83 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
84 %{_mandir}/man3/*
This page took 0.084171 seconds and 2 git commands to generate.