]> git.pld-linux.org Git - packages/perl-Apache-NNTPGateway.git/blob - perl-Apache-NNTPGateway.spec
use generic url
[packages/perl-Apache-NNTPGateway.git] / perl-Apache-NNTPGateway.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Apache
6 %define         pnam    NNTPGateway
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Apache::NNTPGateway - A NNTP interface for mod_perl enabled Apache web server
9 Summary(pl.UTF-8):      Apache::NNTPGateway - interfejs NNTP dla serwera WWW Apache z mod_perlem
10 Name:           perl-Apache-NNTPGateway
11 Version:        0.9
12 Release:        6
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b14703a19ed3c8a763d865a46b6116b5
18 URL:            http://search.cpan.org/dist/Apache-NNTPGateway/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 3.0.3-26
21 %if %{with tests}
22 BuildRequires:  apache1-mod_perl >= 1.20
23 BuildRequires:  perl-CGI >= 1.10
24 BuildRequires:  perl-MailTools >= 1.10
25 BuildRequires:  perl-libnet
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This module implements a per group interface to NNTP (Usenet)
32 News-Groups, it allow users to list, read, post, followup... articles
33 in a given newsgroup/newsserver depending of configuration. This is
34 not a replacement for a real powerful newsreader client but just
35 pretend to be a simple, useful mapping of some news articles into a
36 web space.
37
38 %description -l pl.UTF-8
39 Ten moduł jest implementacją interfejsu do usenetowych grup
40 dyskusyjnych (NNTP). Pozwala użytkownikom przeglądać, czytać, wysyłać,
41 odpowiadać... na artykuły z podanej grupy i serwera, w zależności od
42 konfiguracji. Nie jest to zamiennik klienta newsów z prawdziwego
43 zdarzenia, ale ma być prostym, użytecznym odwzorowaniem artykułów
44 newsowych w przestrzeni WWW.
45
46 %prep
47 %setup -q -n %{pnam}-%{version}
48 %{__perl} -pi -e 's/^(require 5.005)(02;)$/$1_$2/' NNTPGateway.pm
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Change* README
69 %{perl_vendorlib}/%{pdir}/*.pm
70 %{_mandir}/man3/*
This page took 0.071286 seconds and 3 git commands to generate.