]> git.pld-linux.org Git - packages/perl-Apache-NNTPGateway.git/blob - perl-Apache-NNTPGateway.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Apache-NNTPGateway.git] / perl-Apache-NNTPGateway.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Apache
6 %define         pnam    NNTPGateway
7 Summary:        Apache::NNTPGateway - A NNTP interface for mod_perl enabled Apache web server
8 Summary(pl.UTF-8):      Apache::NNTPGateway - interfejs NNTP dla serwera WWW Apache z mod_perlem
9 Name:           perl-Apache-NNTPGateway
10 Version:        0.9
11 Release:        6
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b14703a19ed3c8a763d865a46b6116b5
17 URL:            http://search.cpan.org/dist/Apache-NNTPGateway/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 3.0.3-26
20 %if %{with tests}
21 BuildRequires:  apache1-mod_perl >= 1.20
22 BuildRequires:  perl-CGI >= 1.10
23 BuildRequires:  perl-MailTools >= 1.10
24 BuildRequires:  perl-libnet
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module implements a per group interface to NNTP (Usenet)
31 News-Groups, it allow users to list, read, post, followup... articles
32 in a given newsgroup/newsserver depending of configuration. This is
33 not a replacement for a real powerful newsreader client but just
34 pretend to be a simple, useful mapping of some news articles into a
35 web space.
36
37 %description -l pl.UTF-8
38 Ten moduł jest implementacją interfejsu do usenetowych grup
39 dyskusyjnych (NNTP). Pozwala użytkownikom przeglądać, czytać, wysyłać,
40 odpowiadać... na artykuły z podanej grupy i serwera, w zależności od
41 konfiguracji. Nie jest to zamiennik klienta newsów z prawdziwego
42 zdarzenia, ale ma być prostym, użytecznym odwzorowaniem artykułów
43 newsowych w przestrzeni WWW.
44
45 %prep
46 %setup -q -n %{pnam}-%{version}
47 %{__perl} -pi -e 's/^(require 5.005)(02;)$/$1_$2/' NNTPGateway.pm
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Change* README
68 %{perl_vendorlib}/%{pdir}/*.pm
69 %{_mandir}/man3/*
This page took 0.056007 seconds and 3 git commands to generate.