]> git.pld-linux.org Git - packages/perl-Apache-LogFormat-Compiler.git/blob - perl-Apache-LogFormat-Compiler.spec
fad781d690eac93e47aa58319c90a84101f0ff58
[packages/perl-Apache-LogFormat-Compiler.git] / perl-Apache-LogFormat-Compiler.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         pdir    Apache
6 %define         pnam    LogFormat-Compiler
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Apache::LogFormat::Compiler - Compile a log format string to perl-code
9 Name:           perl-Apache-LogFormat-Compiler
10 Version:        0.13
11 Release:        2
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  fd04ee3f4c2164b7f7909d85f11e467a
16 URL:            http://search.cpan.org/dist/Apache-LogFormat-Compiler/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 3.0.3-26
19 %if %{with tests}
20 BuildRequires:  perl-HTTP-Message
21 BuildRequires:  perl-Try-Tiny
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Compile a log format string to Perl-code. For faster generation of
27 access_log lines.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Build.PL \
34                 destdir=$RPM_BUILD_ROOT \
35                 installdirs=vendor
36 ./Build
37
38 %{?with_tests:./Build test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 ./Build install
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %dir %{perl_vendorlib}/%{pdir}/LogFormat
50 %{perl_vendorlib}/%{pdir}/LogFormat/*.pm
51 %{_mandir}/man3/*.3*
This page took 0.038663 seconds and 2 git commands to generate.