]> git.pld-linux.org Git - packages/perl-Apache-LogFormat-Compiler.git/blob - perl-Apache-LogFormat-Compiler.spec
use generic url
[packages/perl-Apache-LogFormat-Compiler.git] / perl-Apache-LogFormat-Compiler.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         pdir    Apache
6 %define         pnam    LogFormat-Compiler
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Apache::LogFormat::Compiler - Compile a log format string to perl-code
9 Name:           perl-Apache-LogFormat-Compiler
10 Version:        0.13
11 Release:        1
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  fd04ee3f4c2164b7f7909d85f11e467a
16 URL:            http://search.cpan.org/dist/Apache-LogFormat-Compiler/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 3.0.3-26
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Compile a log format string to Perl-code. For faster generation of
23 access_log lines.
24
25 %prep
26 %setup -q -n %{pdir}-%{pnam}-%{version}
27
28 %build
29 %{__perl} Build.PL \
30                 destdir=$RPM_BUILD_ROOT \
31                 installdirs=vendor
32 ./Build
33
34 %{?with_tests:./Build test}
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38
39 ./Build install
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %dir %{perl_vendorlib}/%{pdir}/LogFormat
47 %{perl_vendorlib}/%{pdir}/LogFormat/*.pm
48 %{_mandir}/man3/*.3*
This page took 0.087808 seconds and 3 git commands to generate.