]> git.pld-linux.org Git - packages/perl-Apache-LogFormat-Compiler.git/blob - perl-Apache-LogFormat-Compiler.spec
- up to 0.35
[packages/perl-Apache-LogFormat-Compiler.git] / perl-Apache-LogFormat-Compiler.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         pdir    Apache
6 %define         pnam    LogFormat-Compiler
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Apache::LogFormat::Compiler - Compile a log format string to perl-code
9 Name:           perl-Apache-LogFormat-Compiler
10 Version:        0.35
11 Release:        1
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  cbb0bf041ade8a39f65eadbdf8a346c1
16 URL:            http://search.cpan.org/dist/Apache-LogFormat-Compiler/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 3.0.3-26
19 %if %{with tests}
20 BuildRequires:  perl-HTTP-Message
21 BuildRequires:  perl-POSIX-strftime-Compiler
22 BuildRequires:  perl-Try-Tiny
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Compile a log format string to Perl-code. For faster generation of
28 access_log lines.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Build.PL \
35                 --destdir=$RPM_BUILD_ROOT \
36                 --installdirs=vendor
37 ./Build
38
39 %{?with_tests:./Build test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 ./Build install
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %dir %{perl_vendorlib}/%{pdir}/LogFormat
52 %{perl_vendorlib}/%{pdir}/LogFormat/*.pm
53 %{_mandir}/man3/*.3*
This page took 0.081142 seconds and 3 git commands to generate.