]> git.pld-linux.org Git - packages/perl-Apache-Cookie-Encrypted.git/blob - perl-Apache-Cookie-Encrypted.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Apache-Cookie-Encrypted.git] / perl-Apache-Cookie-Encrypted.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Apache
6 %define         pnam    CookieEncrypted
7 Summary:        Apache::Cookie::Encrypted - encrypted HTTP cookies class
8 Summary(pl.UTF-8):      Apache::Cookie::Encrypted - klasa szyfrowanych ,,cookie'' HTTP
9 Name:           perl-Apache-Cookie-Encrypted
10 Version:        0.03
11 Release:        5
12 # same as Apache::Cookie or perl
13 License:        GPL v1+ or Artistic or Apache Software License 1.1
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d8dac472f79ccfc33418423137f1d4bb
17 URL:            http://search.cpan.org/dist/Apache-CookieEncrypted/
18 BuildRequires:  perl-Crypt-Blowfish >= 2.06
19 BuildRequires:  perl-Crypt-CBC >= 1.25
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  perl-libapreq >= 0.01
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 Requires:       perl(Apache::Cookie) >= 0.01
24 Requires:       perl(Crypt::Blowfish) >= 2.06
25 Requires:       perl(Crypt::CBC) >= 1.25
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Apache::Cookie::Encrypted is a subclass of Apache::Cookie. It takes
31 the value you put in to the cookie and automaticaly encrypts it. It
32 automaticaly decrypts it when the value is retrieved. Other than that
33 it behaves just like Apache::Cookie.
34
35 %description -l pl.UTF-8
36 Apache::Cookie::Encrypted jest podklasą Apache::Cookie. Każda wartość,
37 zapisywana w ,,cookie'' jest automatycznie szyfrowana przy wysyłaniu i
38 rezszyfrowywana po otrzymaniu; poza tym moduł zachowuje się tak samo,
39 jak Apache::Cookie.
40
41 %prep
42 %setup -q -n %{pdir}%{pnam}-%{version}
43
44 %build
45 echo '!' | perl Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %dir %{perl_vendorlib}/Apache/Cookie
64 %{perl_vendorlib}/Apache/Cookie/Encrypted.pm
65 %{_mandir}/man3/*
This page took 0.026733 seconds and 3 git commands to generate.