]> git.pld-linux.org Git - packages/perl-AnyEvent-HTTP.git/blob - perl-AnyEvent-HTTP.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-AnyEvent-HTTP.git] / perl-AnyEvent-HTTP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    AnyEvent
6 %define         pnam    HTTP
7 Summary:        AnyEvent::HTTP - simple but non-blocking HTTP/HTTPS client
8 Summary(pl.UTF-8):      AnyEvent::HTTP - prosty, nieblokujący klient HTTP/HTTPS
9 Name:           perl-AnyEvent-HTTP
10 Version:        2.24
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/AnyEvent/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a65ef37d987f65cd4340c611f4186013
17 URL:            http://search.cpan.org/dist/AnyEvent-HTTP/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-AnyEvent >= 5.33
22 BuildRequires:  perl-common-sense >= 3.30
23 %endif
24 Requires:       perl-AnyEvent >= 5.33
25 Requires:       perl-common-sense >= 3.30
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module implements a simple, stateless and non-blocking HTTP
31 client. It supports GET, POST and other request methods, cookies and
32 more, all on a very low level. It can follow redirects, supports
33 proxies, and automatically limits the number of connections to the
34 values specified in the RFC.
35
36 %description -l pl.UTF-8
37 Ten moduł jest implementacją prostego, bezstanowego i nieblokującego
38 klienta HTTP. Obsługuje GET, POST i inne metody żądań, ciasteczka itd.
39 na bardzo niskim poziomie. Potrafi podążać za przekierowaniami,
40 obsługuje proxy i automatycznie ogranicza liczbę połączeń do wartości
41 określonych w RFC.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc COPYING Changes README
65 %{perl_vendorlib}/AnyEvent/HTTP.pm
66 %{_mandir}/man3/AnyEvent::HTTP.3pm*
This page took 0.068486 seconds and 3 git commands to generate.