]> git.pld-linux.org Git - packages/perl-Alzabo-Display-SWF.git/blob - perl-Alzabo-Display-SWF.spec
use generic url
[packages/perl-Alzabo-Display-SWF.git] / perl-Alzabo-Display-SWF.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # perform "make test"
4
5 %define         pdir    Alzabo
6 %define         pnam    Display-SWF
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Create SWF (Flash) Movies for visualizing Alzabo database schemas
9 Summary(pl.UTF-8):      Tworzenie filmów SWF (Flash) do wizualizacji schematów baz danych Alzabo
10 Name:           perl-Alzabo-Display-SWF
11 Version:        0.01
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  380e05fd0287865310e742756d2a2688
18 Patch0:         %{name}-regexps.patch
19 URL:            http://search.cpan.org/dist/Alzabo-Display-SWF/
20 BuildRequires:  perl-Module-Build
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-Alzabo >= 0.72
25 BuildRequires:  perl-DBD-mysql
26 BuildRequires:  perl-GraphViz >= 1.6
27 BuildRequires:  perl-YAML
28 BuildRequires:  perl-ming
29 %endif
30 Requires:       perl-Alzabo
31 Requires:       perl-GraphViz
32 Requires:       perl-YAML
33 Requires:       perl-ming
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 This Module uses the information provided by an Alzabo database schema
39 and - with the help of the GraphViz module and the Ming library -
40 creates a SWF Movie which contains a visualization of the data model.
41
42 %description -l pl.UTF-8
43 Ten moduł używa informacji dostarczonych przez schemat bazy danych
44 Alzabo i - przy pomocy modułu GraphViz oraz biblioteki Ming - tworzy
45 film SWF zawierający wizualizację modelu danych.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49 %patch0 -p0
50
51 %build
52 %{__perl} Build.PL \
53         installdirs=vendor \
54         destdir=$RPM_BUILD_ROOT
55 ./Build
56
57 %{?with_tests:./Build test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 ./Build install
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README Changes etc/[cm]*
70 %dir %{perl_vendorlib}/Alzabo/Display
71 %{perl_vendorlib}/Alzabo/Display/*
72 %{_mandir}/man3/*
This page took 0.098928 seconds and 3 git commands to generate.