]> git.pld-linux.org Git - packages/perl-Alien-wxWidgets.git/blob - perl-Alien-wxWidgets.spec
- add CC to %{__make}
[packages/perl-Alien-wxWidgets.git] / perl-Alien-wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_with     unicode # use Unicode version of wxGTK2
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    Alien
8 %define         pnam    wxWidgets
9 Summary:        Alien::wxWidgets - building, finding and using wxWidgets binaries
10 Summary(pl.UTF-8):      Alien::wxWidgets - budowanie, znajdowanie i wykorzystywanie binariów wxWidgets
11 Name:           perl-Alien-wxWidgets
12 Version:        0.22
13 Release:        0.1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Alien/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  98de414f8d378170ede6cf96a0e2f73e
19 Patch0:         %{name}-nobuild.patch
20 URL:            http://search.cpan.org/dist/Alien-wxWidgets/
21 BuildRequires:  perl-Module-Build >= 0.2611-1
22 BuildRequires:  perl-Module-Pluggable >= 3.1-4
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  wxGTK2-%{?with_unicode:unicode-}devel >= 2.6.3
26 BuildRequires:  wxGTK2-%{?with_unicode:unicode-}gl-devel >= 2.6.3
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Alien::wxWidgets allows wxPerl to easily find information about your
31 wxWidgets installation. It can store this information for multiple
32 wxWidgets versions or configurations (debug, Unicode, etc.). It can
33 also build and install a private copy of wxWidgets as part of the
34 build process.
35
36 %description -l pl.UTF-8
37 Alien::wxWidgets pozwala wxPerlowi łatwo uzyskać informacje na temat
38 instalacji wxWidgets. Może przechowywać informacje o wielu wersjach
39 lub konfiguracjach (debug, Unicode, itp.). Może także zbudować i
40 zainstalować prywatną kopię wxWidgets jako część procesu budowania.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44 %patch0 -p1
45
46 %build
47 WX_CONFIG=wx-gtk2-%{?with_unicode:unicode}%{!?with_unicode:ansi}-config
48 export WX_CONFIG
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51
52 %{__make} \
53         CC="%{__cc}" \
54         OPTIMIZE="%{rpmcflags}"
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %dir %{perl_vendorarch}/Alien
70 %{perl_vendorarch}/Alien/*.pm
71 %dir %{perl_vendorarch}/Alien/wxWidgets
72 %{perl_vendorarch}/Alien/wxWidgets/*.pm
73 %dir %{perl_vendorarch}/auto/Alien
74 %dir %{perl_vendorarch}/auto/Alien/wxWidgets
75 %{perl_vendorarch}/auto/Alien/wxWidgets/*
76 %{_mandir}/man3/*
This page took 0.027473 seconds and 4 git commands to generate.