]> git.pld-linux.org Git - packages/perl-Alien-wxWidgets.git/blob - perl-Alien-wxWidgets.spec
- saving work, not working yet, help needed
[packages/perl-Alien-wxWidgets.git] / perl-Alien-wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_with unicode
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    Alien
8 %define         pnam    wxWidgets
9 Summary:        Alien::wxWidgets - building, finding and using wxWidgets binaries
10 Summary(pl):    Alien::wxWidgets - budowanie, znajdowanie i wykorzystywanie binariów wxWidgets
11 Name:           perl-Alien-wxWidgets
12 Version:        0.22
13 Release:        1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Alien/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  98de414f8d378170ede6cf96a0e2f73e
19 Patch0:     %{name}-nobuild.patch
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  perl-Module-Build >= 0.2611-1
22 BuildRequires:  perl-Module-Pluggable >= 3.1-4
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  wxGTK2-%{?with_unicode:unicode-}devel >= 2.6.3
25 BuildRequires:  wxGTK2-%{?with_unicode:unicode-}gl-devel >= 2.6.3
26
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Alien::wxWidgets allows wxPerl to easily find information about your wxWidgets installation.
31 It can store this information for multiple wxWidgets versions or configurations
32 (debug, Unicode, etc.). It can also build and install a private copy of wxWidgets
33 as part of the build process.
34
35 %description -l pl
36 Alien::wxWidgets pozwala wxPerlowi ³atwo uzyskaæ informacje na temat instalacji wxWidgets.
37 Mo¿e przechowywaæ informacje o wielu wersjach lub konfiguracjach (debug, Unicode, itp.).
38 Mo¿e tak¿e zbudowaæ i zainstalowaæ prywatn± kopiê wxWidgets jako czê¶æ procesu budowania.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42 %patch0 -p1
43
44 %build
45 WX_CONFIG=wx-gtk2-%{?with_unicode:unicode}%{!?with_unicode:ansi}-config
46 export WX_CONFIG
47 %{__perl} Makefile.PL \
48     INSTALLDIRS=vendor
49     
50 %{__make} \
51     OPTIMIZE="%{rpmcflags}"
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %dir %{perl_vendorarch}/Alien
67 %{perl_vendorarch}/Alien/*.pm
68 %dir %{perl_vendorarch}/Alien/wxWidgets
69 %{perl_vendorarch}/Alien/wxWidgets/*.pm
70 %dir %{perl_vendorarch}/auto/Alien
71 %dir %{perl_vendorarch}/auto/Alien/wxWidgets
72 %{perl_vendorarch}/auto/Alien/wxWidgets/*
73 %{_mandir}/man3/*
This page took 0.053253 seconds and 4 git commands to generate.