]> git.pld-linux.org Git - packages/perl-Alien-Base-ModuleBuild.git/blob - perl-Alien-Base-ModuleBuild.spec
- new, split from perl-Alien-Build
[packages/perl-Alien-Base-ModuleBuild.git] / perl-Alien-Base-ModuleBuild.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Alien
6 %define         pnam    Base-ModuleBuild
7 Summary:        Alien::Base::ModuleBuild - Module::Build subclass for building Alien:: modules and their libraries
8 Summary(pl.UTF-8):      Alien::Base::ModuleBuild - podklasa Module::Build do budowania modułów Alien:: oraz ich bibliotek
9 Name:           perl-Alien-Base-ModuleBuild
10 Version:        1.14
11 Release:        1
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Alien/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d9480f0c8891428950eb35536026ded0
17 URL:            https://metacpan.org/release/Alien-Base-ModuleBuild
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Shell-Config-Generate
24 BuildRequires:  perl-Shell-Guess
25 BuildRequires:  perl-Alien-Base >= 1.20
26 BuildRequires:  perl-Capture-Tiny >= 0.17
27 BuildRequires:  perl-File-chdir >= 0.1005
28 BuildRequires:  perl-Path-Tiny >= 0.077
29 BuildRequires:  perl-Sort-Versions
30 BuildRequires:  perl-URI
31 BuildRequires:  perl-Test2-Suite >= 0.000060
32 %endif
33 Requires:       perl-Alien-Base >= 1.20
34 Requires:       perl-File-chdir >= 0.1005
35 Requires:       perl-Path-Tiny >= 0.077
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 This is a subclass of Module::Build, that with Alien::Base allows for
41 easy creation of Alien distributions. This module is used during the
42 build step of your distribution. When properly configured it will:
43 - use pkg-config to find and use the system version of the library
44 - download, build and install the library if the system does not
45   provide it.
46
47 NOTE: Please consider for new development of Aliens that you use
48 Alien::Build and alienfile instead. Like this module they work with
49 Alien::Base. Unlike this module they are more easily customized and
50 handle a number of corner cases better.
51
52 %description -l pl.UTF-8
53 Ten pakiet zawiera podklasę Module::Build, która w połączeniu z
54 Alien::Base pozwala na łatwe tworzenie pakietów Aliena. Ten moduł jest
55 używany podczas kroku budowania pakietu. Przy poprawnym
56 skonfigurowaniu:
57 - użyje pkg-configa do znalezienia i używania systemowej wersji
58   biblioteki
59 - pobierze, zbuduje i zainstaluje bibliotekę, jeśli system jej nie
60   dostarcza.
61
62 UWAGA: do tworzenia nowych Alienów należy rozważyć użycie Alien::Build
63 i alienfile zamiast tego pakietu. Podobnie jak ten moduł działają z
64 Alien::Base, ale można je łatwiej dostosować i lepiej obsługują wiele
65 przypadków brzegowych.
66
67 %prep
68 %setup -q -n %{pdir}-%{pnam}-%{version}
69
70 %build
71 %{__perl} Build.PL \
72         destdir=$RPM_BUILD_ROOT \
73         installdirs=vendor
74 ./Build
75
76 %{?with_tests:./Build test}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 ./Build install
82
83 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Alien/Base/ModuleBuild/*.pod
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc Changes INSTALL README
91 %{perl_vendorlib}/Alien/Base/ModuleBuild.pm
92 %{perl_vendorlib}/Alien/Base/ModuleBuild
93 %{_mandir}/man3/Alien::Base::ModuleBuild*.3pm*
This page took 0.072727 seconds and 3 git commands to generate.