]> git.pld-linux.org Git - packages/perl-Algorithm-SVM.git/blob - perl-Algorithm-SVM.spec
perl 5.38.0 rebuild
[packages/perl-Algorithm-SVM.git] / perl-Algorithm-SVM.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make test"
4 #
5 %define         pdir    Algorithm
6 %define         pnam    SVM
7 Summary:        Perl bindings for the libsvm Support Vector Machine library
8 Summary(pl.UTF-8):      Dowiązania Perla do biblioteki libsvm (Support Vector Machine)
9 Name:           perl-Algorithm-SVM
10 Version:        0.13
11 Release:        17
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Algorithm/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  276ec1b341e05aa4c0353685f32ea4d5
17 URL:            http://search.cpan.org/dist/Algorithm-SVM/
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  sed >= 4.0
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Algorithm::SVM implements a Support Vector Machine for Perl. Support
26 Vector Machines provide a method for creating classification functions
27 from a set of labeled training data, from which predictions can be
28 made for subsequent data sets.
29
30 %description -l pl.UTF-8
31 Moduł Algorithm::SVM jest implementacją Support Vector Machine dla
32 Perla. Support Vector Machines udostępniają sposób tworzenia funkcji
33 klasyfikujących ze zbioru oznaczonych danych treningowych, z których
34 można dokonywać przewidywań co do kolejnych zbiorów danych.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %{__sed} -i -e 's/#include <errno.h>/#include <errno.h>\n#include <stdlib.h>\n#include <string.h>/g' bindings.cpp
40
41 %build
42 %{__perl} Makefile.PL \
43         CCFLAGS="%{rpmcflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" \
44         INSTALLDIRS=vendor
45
46 # cc1plus: warning: command line option "-Wdeclaration-after-statement" is valid for C/ObjC but not for C++
47 %{__sed} -i -e 's/-Wdeclaration-after-statement//' Makefile
48
49 %{__make} \
50         CC="%{__cxx}" \
51         OPTIMIZE="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
62 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Algorithm/SVM/.packlist
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorarch}/Algorithm/*.pm
71 %{perl_vendorarch}/Algorithm/SVM
72 %dir %{perl_vendorarch}/auto/Algorithm/SVM
73 %{perl_vendorarch}/auto/Algorithm/SVM/*.ix
74 %attr(755,root,root) %{perl_vendorarch}/auto/Algorithm/SVM/*.so
75 %{_mandir}/man3/*
This page took 0.129365 seconds and 4 git commands to generate.