]> git.pld-linux.org Git - packages/perl-Algorithm-NaiveBayes.git/blob - perl-Algorithm-NaiveBayes.spec
356ff0d15cc4748afd0bf9396abc6a8fca3c5fa3
[packages/perl-Algorithm-NaiveBayes.git] / perl-Algorithm-NaiveBayes.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Algorithm
7 %define         pnam    NaiveBayes
8 Summary:        Algorithm::NaiveBayes - Bayesian prediction of categories
9 Summary(pl.UTF-8):      Algorithm::NaiveBayes - bayesowskie przewidywanie kategorii
10 Name:           perl-Algorithm-NaiveBayes
11 Version:        0.04
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  bd461c9ea2f140a75d5364cc98c2ef09
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module implements the classic "Naive Bayes" machine learning
25 algorithm. It is a well-studied probabilistic algorithm often used in
26 automatic text categorization. Compared to other algorithms (kNN, SVM,
27 Decision Trees), it's pretty fast and reasonably competitive in the
28 quality of its results.
29
30 %description -l pl.UTF-8
31 Ten moduł jest implementacją klasycznego "naiwnego bayesowskiego"
32 algorytmu uczenia maszyny. Jest to dobrze przestudiowany algorytm
33 probabilistyczny często używany przy automatycznej kategoryzacji
34 tekstu. W porównaniu do innych algorytmów (kNN, SVM, drzewa decyzyjne)
35 jest dość szybki i w miarę konkurencyjny jeśli chodzi o jakość
36 wyników.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Change*
60 %{perl_vendorlib}/Algorithm/*.pm
61 %{perl_vendorlib}/Algorithm/NaiveBayes
62 %{_mandir}/man3/*
This page took 0.083029 seconds and 2 git commands to generate.