]> git.pld-linux.org Git - packages/perl-Algorithm-Huffman.git/blob - perl-Algorithm-Huffman.spec
use generic url
[packages/perl-Algorithm-Huffman.git] / perl-Algorithm-Huffman.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make test"
4
5 %define         pdir    Algorithm
6 %define         pnam    Huffman
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Algorithm::Huffman - implementation of the Huffman algorithm
9 Summary(pl.UTF-8):      Algorithm::Huffman - implementacja algorytmu Huffmana
10 Name:           perl-Algorithm-Huffman
11 Version:        0.09
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  dd5c0360357dcb0807e9ac2e49b2e746
18 URL:            http://search.cpan.org/dist/Algorithm-Huffman/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Heap
23 BuildRequires:  perl-Scalar-List-Utils
24 BuildRequires:  perl-String-Random
25 BuildRequires:  perl-Test-Exception
26 BuildRequires:  perl-Test-ManyParams
27 BuildRequires:  perl-Test-Simple
28 BuildRequires:  perl-Tree-DAG_Node
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This modules implements the huffman algorithm. The aim is to create a
35 good coding scheme for a given list of different characters (or even
36 strings) and their occurence numbers.
37
38 %description -l pl.UTF-8
39 Ten moduł jest implementacją algorytmu Huffmana. Celem jest stworzenie
40 dobrze kodującego schematu dla danej listy różnych znaków (lub nawet
41 ciągów) i liczby ich wystąpień.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Change*
65 %{perl_vendorlib}/%{pdir}/*.pm
66 %{_mandir}/man3/*
This page took 0.08394 seconds and 3 git commands to generate.