]> git.pld-linux.org Git - packages/perl-Algorithm-Combinatorics.git/blob - perl-Algorithm-Combinatorics.spec
- initial, version 0.27
[packages/perl-Algorithm-Combinatorics.git] / perl-Algorithm-Combinatorics.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Algorithm
7 %define         pnam    Combinatorics
8 Summary:        Efficient generation of combinatorial sequences 
9 Name:           perl-Algorithm-Combinatorics
10 Version:        0.27
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Algorithm/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  bada976399f9edfe364d6fcf9e0bcde2
17 URL:            http://search.cpan.org/dist/Algorithm-Combinatorics/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  perl(Scalar::Util)
20 %if %{with tests}
21 BuildRequires:  perl(Test::More)
22 %endif
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  sed >= 4.0
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Algorithm::Combinatorics is an efficient generator of combinatorial
29 sequences. Algorithms are selected from the literature (work in
30 progress, see "REFERENCES"). Iterators do not use recursion, nor
31 stacks, and are written in C.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39
40 %{__make} \
41         CC="%{__cc}"
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorarch}/Algorithm/Combinatorics.pm
59 %dir %{perl_vendorarch}/auto/Algorithm/Combinatorics
60 %attr(755,root,root) %{perl_vendorarch}/auto/Algorithm/Combinatorics/Combinatorics.so
61 %{_mandir}/man3/*.3pm.gz
This page took 0.057181 seconds and 3 git commands to generate.