]> git.pld-linux.org Git - packages/perl-Acme-Damn.git/blob - perl-Acme-Damn.spec
a005d720e38d1010ab6db9dc7972f2b90ae2f437
[packages/perl-Acme-Damn.git] / perl-Acme-Damn.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Acme
7 %define pnam    Damn
8 Summary:        Acme::Damn - 'Unbless' Perl objects
9 Summary(pl.UTF-8):      Acme::Damn - "odbłogosławianie" obiektów Perla
10 Name:           perl-Acme-Damn
11 Version:        0.04
12 Release:        5
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  71b2eabfe0601c7d9ff850aab5f86567
18 BuildRequires:  perl-Test-Exception
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Acme::Damn provides a single routine, damn(), which takes a blessed
25 reference (a Perl object), and unblesses it, to return the original
26 reference. I can't think of any reason why you might want to do this,
27 but just because it's of no use doesn't mean that you shouldn't be
28 able to do it.
29
30 %description -l pl.UTF-8
31 Acme::Damn dostarcza jedną funkcję: damn(), która przyjmuje
32 pobłogosławioną referencję (obiekt perlowy) i odbłogosławia ją, aby
33 zwrócić oryginalną referencję. Nie znaleziono na razie powodu, żeby to
34 robić, ale to, że takie działanie nie ma zastosowania, nie znaczy, że
35 nie powinno dać się tego zrobić.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %dir %{perl_vendorarch}/Acme
62 %{perl_vendorarch}/Acme/*.pm
63 %dir %{perl_vendorarch}/auto/Acme
64 %dir %{perl_vendorarch}/auto/Acme/Damn
65 %attr(755,root,root) %{perl_vendorarch}/auto/Acme/Damn/*.so
66 %{_mandir}/man3/*
This page took 0.196948 seconds and 2 git commands to generate.