]> git.pld-linux.org Git - packages/perl-Acme-Damn.git/blob - perl-Acme-Damn.spec
17e04278b04e2f86e303cd3ed7b13d383ff2273e
[packages/perl-Acme-Damn.git] / perl-Acme-Damn.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Acme
6 %define pnam    Damn
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Acme::Damn - 'Unbless' Perl objects
9 Summary(pl.UTF-8):      Acme::Damn - "odbłogosławianie" obiektów Perla
10 Name:           perl-Acme-Damn
11 Version:        0.06
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  49967bcae23d97ee8db5eaa1bcca7d2d
18 URL:            http://search.cpan.org/dist/Acme-Damn/
19 BuildRequires:  perl-Test-Exception
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Acme::Damn provides a single routine, damn(), which takes a blessed
26 reference (a Perl object), and unblesses it, to return the original
27 reference. I can't think of any reason why you might want to do this,
28 but just because it's of no use doesn't mean that you shouldn't be
29 able to do it.
30
31 %description -l pl.UTF-8
32 Acme::Damn dostarcza jedną funkcję: damn(), która przyjmuje
33 pobłogosławioną referencję (obiekt perlowy) i odbłogosławia ją, aby
34 zwrócić oryginalną referencję. Nie znaleziono na razie powodu, żeby to
35 robić, ale to, że takie działanie nie ma zastosowania, nie znaczy, że
36 nie powinno dać się tego zrobić.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %dir %{perl_vendorarch}/Acme
63 %{perl_vendorarch}/Acme/*.pm
64 %dir %{perl_vendorarch}/auto/Acme
65 %dir %{perl_vendorarch}/auto/Acme/Damn
66 %attr(755,root,root) %{perl_vendorarch}/auto/Acme/Damn/*.so
67 %{_mandir}/man3/*
This page took 0.041017 seconds and 2 git commands to generate.