]> git.pld-linux.org Git - packages/perl-AI-jNeural.git/blob - perl-AI-jNeural.spec
d25d537d367c8571b65b04df4367f2f248b15c15
[packages/perl-AI-jNeural.git] / perl-AI-jNeural.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # don't perform "make test"
4 #
5 # please, check it again 
6 #%ifarch ppc
7 #%%undefine     with_tests
8 #%endif
9
10 %include        /usr/lib/rpm/macros.perl
11 %define         pdir    AI
12 %define         pnam    jNeural
13 Summary:        AI::jNeural::arch - the Jet's Neural Architecture base module
14 Summary(pl.UTF-8):      AI::jNeural::arch - podstawowy moduł Jet's Neural Architecture
15 Name:           perl-AI-jNeural
16 Version:        0.53
17 Release:        3
18 License:        unknown
19 Group:          Development/Languages/Perl
20 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
21 # Source0-md5:  0f6ffe4b60bd7d82bd7aafcfc3b96d36
22 BuildRequires:  flex
23 BuildRequires:  jneural-devel
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 %{?with_tests:BuildRequires:    perl-Math-Business-SMA}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This particular module doesn't actually do anything. It would be the
31 place to look for functions that are general to the entire library,
32 but there really aren't any yet.
33
34 %description -l pl.UTF-8
35 Ten moduł nie robi właściwie niczego. Ma być miejscem do szukania
36 funkcji, które są ogólne dla całej biblioteki, ale takich jeszcze nie
37 ma.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 find -type f | xargs perl -pi -e 's,/usr/local,/usr,g'
44 %{__perl} Makefile.PL skip_stuff \
45         INSTALLDIRS=vendor
46 %{__make}
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %dir %{perl_vendorarch}/AI
61 %{perl_vendorarch}/AI/*.pm
62 %{perl_vendorarch}/AI/jNeural
63 %dir %{perl_vendorarch}/auto/AI
64 %dir %{perl_vendorarch}/auto/AI/jNeural
65 # empty autosplit.ix files
66 #%%{perl_vendorarch}/auto/AI/jNeural/*.ix
67 #%%{perl_vendorarch}/auto/AI/jNeural/*/*.ix
68 #%%{perl_vendorarch}/auto/AI/jNeural/*/*/*.ix
69 %attr(755,root,root) %{perl_vendorarch}/auto/AI/jNeural/*.so
70 %attr(755,root,root) %{perl_vendorarch}/auto/AI/jNeural/*/*/*.so
71 %dir %{perl_vendorarch}/auto/AI/jNeural/arch
72 %dir %{perl_vendorarch}/auto/AI/jNeural/arch/neuron
73 %dir %{perl_vendorarch}/auto/AI/jNeural/nets
74 %dir %{perl_vendorarch}/auto/AI/jNeural/nets/backprop
75 %dir %{perl_vendorarch}/auto/AI/jNeural/nets/kohonen
76 %dir %{perl_vendorarch}/auto/AI/jNeural/utils
77 %dir %{perl_vendorarch}/auto/AI/jNeural/utils/transfer
78 %{_mandir}/man3/*
This page took 0.088981 seconds and 2 git commands to generate.