]> git.pld-linux.org Git - packages/perl-AI-NNEasy.git/blob - perl-AI-NNEasy.spec
49681c23625df02e185dcf070164336fe8c9bf93
[packages/perl-AI-NNEasy.git] / perl-AI-NNEasy.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    AI
7 %define pnam    NNEasy
8 Summary:        AI::NNEasy - Define, learn and use easy Neural Networks of different types
9 Summary(pl.UTF-8):      AI::NNEasy - definiowanie, uczenie i używanie łatwych sieci neuronowych
10 Name:           perl-AI-NNEasy
11 Version:        0.06
12 Release:        7
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/G/GM/GMPASSOS/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  110f3b4b0e0f2575ef4f8dd3dfc8a0e4
18 BuildRequires:  perl-Class-HPLOO >= 0.21
19 BuildRequires:  perl-Inline >= 0.44
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The main purpose of this module is to create easy Neural Networks with
26 Perl.
27
28 The module was designed to can be extended to multiple network types,
29 learning algorithms and activation functions. This architecture was
30 1st based in the module AI::NNFlex, than I have rewrited it to fix
31 some serialization bugs, and have otimized the code and added some XS
32 functions to get speed in the learning process. Finally I have added
33 an intuitive inteface to create and use the NN, and added a winner
34 algorithm to the output.
35
36 I have writed this module because after test different NN module on
37 Perl I can't find one that is portable through Linux and Windows, easy
38 to use and the most important, one that really works in a real
39 problem.
40
41 With this module you don't need to learn much about NN to be able to
42 construct one, you just define the construction of the NN, learn your
43 set of inputs, and use it.
44
45 %description -l pl.UTF-8
46 Głównym celem tego modułu jest tworzenie łatwych sieci neuronowych
47 (Neural Networks, w skrócie NN) w Perlu.
48
49 Moduł został zaprojektowany tak, aby można było go rozszerzać do wielu
50 rodzajów sieci, algorytmów uczących czy funkcji aktywacyjnych.
51 Architektura ta została najpierw oparta na module AI::NNFlex,
52 następnie przepisana w celu poprawienia błędów serializacji,
53 zoptymalizowana wraz z dodaniem funkcji XS w celu poprawienia
54 szybkości w procesie uczenia. Ostatecznie dodano intuicyjny interfejs
55 do tworzenia i używania sieci neuronowych oraz dodano algorytm
56 zwycięzcy na wyjściu.
57
58 Moduł ten został napisany ponieważ po testach różnych modułów do sieci
59 neuronowych autor nie znalazł żadnego wystarczająco przenośnego między
60 Linuksem a Windows, łatwego w użyciu i co najważniejsze naprawdę
61 działającego przy rzeczywistych problemach.
62
63 Przy użyciu tego modułu nie trzeba uczyć się zbyt wiele o sieciach
64 neuronowych aby móc takową skonstruować, wystarczy zdefiniować
65 konstrukcję sieci, nauczyć zbiór wejść i używać.
66
67 %prep
68 %setup -q -n %{pdir}-%{pnam}-%{version}
69
70 %build
71 %{__perl} Makefile.PL \
72         INSTALLDIRS=vendor
73 %{__make}
74
75 %{?with_tests:%{__make} test}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
84 cp -a samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc Changes README
92 %{perl_vendorarch}/AI/*.*
93 %{perl_vendorarch}/AI/NNEasy
94 %dir %{perl_vendorarch}/auto/AI/NNEasy
95 %dir %{perl_vendorarch}/auto/AI/NNEasy/NN
96 %dir %{perl_vendorarch}/auto/AI/NNEasy/NN/[bf]*
97 %attr(755,root,root) %{perl_vendorarch}/auto/AI/NNEasy/*.so
98 %attr(755,root,root) %{perl_vendorarch}/auto/AI/NNEasy/*/*.so
99 %attr(755,root,root) %{perl_vendorarch}/auto/AI/NNEasy/*/*/*.so
100 %{_mandir}/man3/*
101 %{_examplesdir}/%{name}-%{version}
This page took 0.041361 seconds and 2 git commands to generate.