]> git.pld-linux.org Git - packages/pdns.git/blob - pdns.spec
- added config hack for 64bit machines
[packages/pdns.git] / pdns.spec
1 Summary:        PowerDNS is a Versatile Database Driven Nameserver
2 Summary(pl.UTF-8):      PowerDNS to wielofunkcyjny serwer nazw korzystający z relacyjnych baz danych
3 Name:           pdns
4 Version:        2.9.21.1
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://downloads.powerdns.com/releases/%{name}-%{version}.tar.gz
9 # Source0-md5:  27fd39029a80cb9c0bc3037420515d1a
10 Source1:        http://downloads.powerdns.com/documentation/%{name}.pdf
11 # Source1-md5:  920b1660258fa2f6d6f949f0c60857b4
12 Source2:        http://downloads.powerdns.com/documentation/%{name}.txt
13 Source3:        %{name}.init
14 Source4:        %{name}.conf
15 Source5:        %{name}.sysconfig
16 Patch0:         %{name}-configure.patch
17 Patch1:         %{name}-int16.patch
18 Patch2:         %{name}-openldap-2.3.patch
19 URL:            http://www.powerdns.com/
20 BuildRequires:  bison
21 BuildRequires:  boost-devel >= 1.35.0
22 BuildRequires:  flex
23 BuildRequires:  libpq++-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  mysql-devel
26 BuildRequires:  openldap-devel >= 2.4.6
27 BuildRequires:  rpmbuild(macros) >= 1.268
28 BuildRequires:  zlib-devel
29 Requires(post): sed >= 4.0
30 Requires(post,preun):   /sbin/chkconfig
31 Requires(postun):       /usr/sbin/groupdel
32 Requires(postun):       /usr/sbin/userdel
33 Requires(pre):  /bin/id
34 Requires(pre):  /usr/bin/getgid
35 Requires(pre):  /usr/sbin/groupadd
36 Requires(pre):  /usr/sbin/useradd
37 Requires:       rc-scripts
38 Provides:       group(djbdns)
39 Provides:       nameserver
40 Provides:       user(pdns)
41 Obsoletes:      powerdns
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 PowerDNS is a versatile nameserver which supports a large number of
46 different backends ranging from simple zonefiles to relational
47 databases and load balancing/failover algorithms.
48
49 %description -l pl.UTF-8
50 PowerDNS to wielofunkcyjny serwer nazw posiadający dużą liczbę wtyczek
51 od prostych stref (a'la BIND) począwszy, a na relacyjnych bazach
52 danych skończywszy oraz zawierający algorytmy zrównoważenia obciążenia
53 i przełączania w wypadku awarii.
54
55 %package backend-pipe
56 Summary:        PowerDNS support for custom pipe backend
57 Summary(pl.UTF-8):      Wsparcie PowerDNS dla własnego mechanizmu przechowywania stref
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60
61 %description backend-pipe
62 This package allows creation of own backend using simple STDIN/STDOUT
63 API. Example backend script in Perl is provided in package
64 documentation.
65
66 %description backend-pipe -l pl.UTF-8
67 Ten pakiet pozwala na utworzenie własnego mechanizmu przechowywania
68 stref za pomocą prostego interfejsu STDIN/STDOUT. Przykładowy skrypt w
69 Perlu został dołączony do dokumentacji pakietu.
70
71 %package backend-gpgsql
72 Summary:        PowerDNS support for PostgreSQL
73 Summary(pl.UTF-8):      Wsparcie PowerDNS dla baz PostgresQL
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76
77 %description backend-gpgsql
78 This package allows zone storage in PostgreSQL relational db tables.
79
80 %description backend-gpgsql -l pl.UTF-8
81 Ten pakiet pozwala na przechowywanie danych o strefach w tabelach
82 relacyjnej bazy danych PostgreSQL.
83
84 %package backend-gmysql
85 Summary:        PowerDNS support for MySQL
86 Summary(pl.UTF-8):      Wsparcie PowerDNS dla baz MySQL
87 Group:          Development/Libraries
88 Requires:       %{name} = %{version}-%{release}
89
90 %description backend-gmysql
91 This package allows zone storage in MySQL relational db tables.
92
93 %description backend-gmysql -l pl.UTF-8
94 Ten pakiet pozwala na przechowywanie danych o strefach w tabelach
95 relacyjnej bazy danych MySQL.
96
97 %package backend-ldap
98 Summary:        PowerDNS support for LDAP
99 Summary(pl.UTF-8):      Wsparcie PowerDNS dla baz LDAP
100 Group:          Development/Libraries
101 Requires:       %{name} = %{version}-%{release}
102
103 %description backend-ldap
104 This package allows zone storage in LDAP directory.
105
106 %description backend-ldap -l pl.UTF-8
107 Ten pakiet pozwala na przechowywanie danych o strefach w katalogu
108 LDAP.
109
110 %prep
111 %setup -q
112 %patch0 -p1
113 %patch1 -p1
114 %patch2 -p1
115 cp %{SOURCE1} .
116 cp %{SOURCE2} .
117 cp %{SOURCE4} .
118
119 %if "%{_lib}" == "lib64"
120 %{__sed} -i -e 's/module-dir=\/usr\/lib\/pdns/module-dir=\/usr\/lib64\/pdns/' pdns.conf
121 %endif
122
123 %build
124 CPPFLAGS="-DHAVE_NAMESPACE_STD -DHAVE_CXX_STRING_HEADER -DDLLIMPORT=\"\""
125 %configure \
126         --libdir=%{_libdir}/%{name} \
127         --sysconfdir=%{_sysconfdir}/%{name} \
128         --with-socketdir=/var/run \
129         --with-dynmodules="gmysql gpgsql pipe ldap" \
130         --with-modules="" \
131         --enable-mysql \
132         --enable-pgsql \
133         --with-pgsql-lib=%{_libdir} \
134         --with-pgsql-includes=%{_includedir} \
135         --with-mysql-lib=%{_libdir} \
136         --with-mysql-includes=%{_includedir} \
137         --enable-ldap \
138         --disable-static
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_sysconfdir}/%{name},/etc/sysconfig}
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
150 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/%{name}.conf
151 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/pdns
152
153 # useless - modules are dlopened by *.so
154 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %pre
160 %groupadd -g 32 djbdns
161 %useradd -u 30 -d /var/lib/pdns -s /bin/false -c "pdns User" -g djbdns pdns
162
163 %post
164 # dirty hack so the config file is processed correctly, and server does not respawn
165 sed -i -e 's/^ *//' /etc/pdns/pdns.conf
166
167 /sbin/chkconfig --add pdns
168 %service pdns restart
169
170 %preun
171 if [ "$1" = "0" ]; then
172         %service pdns stop
173         /sbin/chkconfig --del pdns
174 fi
175
176 %postun
177 if [ "$1" = "0" ]; then
178         %userremove pdns
179         %groupremove djbdns
180 fi
181
182 %files
183 %defattr(644,root,root,755)
184 %doc ChangeLog HACKING INSTALL README TODO pdns.pdf pdns.txt
185 %attr(754,root,root) /etc/rc.d/init.d/%{name}
186 %dir %{_sysconfdir}/%{name}
187 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
188 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/pdns
189 %attr(755,root,root) %{_sbindir}/*
190 %attr(755,root,root) %{_bindir}/*
191 %dir %{_libdir}/%{name}
192 %{_mandir}/man8/*
193
194 %files backend-gmysql
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/%{name}/*mysql*.so*
197
198 %files backend-gpgsql
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libdir}/%{name}/*pgsql*.so*
201
202 %files backend-pipe
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_libdir}/%{name}/*pipe*.so*
205
206 %files backend-ldap
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_libdir}/%{name}/*ldap*.so*
This page took 0.0640770000000001 seconds and 4 git commands to generate.