]> git.pld-linux.org Git - packages/partimage.git/blob - partimage.spec
Fix build with zlib >= 1.2.6 (patch from Fedora)
[packages/partimage.git] / partimage.spec
1 Summary:        Utility to save partitions in a compressed image file
2 Summary(pl.UTF-8):      Narzędzie do zapisu partycji w skompresowanych plikach
3 Summary(pt_BR.UTF-8):   Ferramenta para criar e restaurar backup de partições
4 Name:           partimage
5 Version:        0.6.9
6 Release:        3
7 License:        GPL v2
8 Group:          Applications/System
9 Source0:        http://downloads.sourceforge.net/partimage/%{name}-%{version}.tar.bz2
10 # Source0-md5:  1bc046fd915c5debbafc85729464e513
11 Source1:        %{name}d.init
12 Source2:        %{name}d.sysconfig
13 Source3:        %{name}d.pam
14 Source4:        %{name}d-ssl.cnf
15 Patch0:         %{name}-fix_debug.patch
16 Patch1:         %{name}-descr.patch
17 Patch2:         %{name}-gzFile.patch
18 URL:            http://www.partimage.org/
19 BuildRequires:  automake
20 BuildRequires:  bzip2-devel
21 BuildRequires:  gettext-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  newt-devel
24 BuildRequires:  openssl-devel
25 BuildRequires:  pam-devel
26 BuildRequires:  rpmbuild(macros) >= 1.202
27 BuildRequires:  slang-devel >= 2.0.0
28 BuildRequires:  zlib-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Linux/UNIX utility to save partitions in a compressed image file
33 Partition Image is a Linux/UNIX partition imaging utility: it saves
34 partitions in the:
35
36   - Ext2FS (the Linux standard)
37   - ReiserFS (a new, powerful journalling file system)
38   - NTFS (Windows NT File System)
39   - FAT16/32 (DOS & Windows file systems)
40   - HPFS (OS/2 File System)
41   - JFS (IBM Jounalized File System for AIX)
42   - XFS (SGI Jounalized File System for IRIX)
43   - HFS (Hierarchical File System for MacOS)
44   - UFS (*BSD, Solaris and NextStep file systems)
45
46 file system formats to an image file. Only used blocks are copied. The
47 image file can be compressed in the GZIP/BZIP2 formats to save disk
48 space, and splitted into multiple files to be copied on amovibles
49 floppies (ZIP for example), or burned on a CD-R ... This allows to
50 save a full Linux/Windows system, with an only operation. When
51 problems (viruses, crash, error, ...), you just have to restore, and
52 after several minutes, all your system is restored (boot, files, ...),
53 and fully working. This is very useful when installing the same
54 software on many machines: just install one of them, create an image,
55 and just restore the image on all other machines. Then, after the
56 first one, each installation is automatically made, and only require a
57 few minutes.
58
59 %description -l pl.UTF-8
60 Narzędzie linuksowe do zapisywania partycji w skompresowanych plikach.
61 Potrafi ono zapisywać partycje:
62   - Ext2FS (linuksowy standard),
63   - ReiserFS (nowy, potężny system plików z journalem),
64   - NTFS (system plików Windows NT),
65   - FAT16/32 (system plików DOS i Windows),
66   - HPFS (system plików OS/2),
67   - XFS (system plików z journalem IBM-a dla AIX),
68   - JFS (system plików z journalem SGI dla IRIX-a),
69   - HFS (hierarchiczny system plików dla MacOS),
70   - UFS (system plików *BSD, Solarisa oraz NextStepa).
71
72 Kopiowane sątylko używane bloki. Plik wyjściowy może być podzielony na
73 wiele mniejszych oraz kompresowany w formacie gzip/bzip2 w celu
74 zaoszczędzenia miejsca. Pozwala to na zapis całego systemu
75 Linux/Windows w pojedynczej operacji. W razie problemów (wirusy,
76 błędy, awaria...) należy po prostu przywrócić system i po kilku
77 minutach całość jest znowu sprawna. Jest to bardzo użyteczne przy
78 instalowaniu tego samego na wielu maszynach: wystarczy zainstalować na
79 jednej z nich, zrobić obraz i przywrócić na pozostałych maszynach. Po
80 pierwszej instalacji każda następna wymaga tylko kilku minut.
81
82 %package server
83 Summary:        Partimage server
84 Summary(pl.UTF-8):      Serwer Partimage
85 Group:          Applications/System
86 Requires(post,preun):   /sbin/chkconfig
87 Requires(postun):       /usr/sbin/groupdel
88 Requires(postun):       /usr/sbin/userdel
89 Requires(pre):  /bin/id
90 Requires(pre):  /usr/bin/getgid
91 Requires(pre):  /usr/sbin/groupadd
92 Requires(pre):  /usr/sbin/useradd
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       openssl-tools
95 Provides:       group(partimag)
96 Provides:       user(partimag)
97
98 %description server
99 Server for Partimage.
100
101 %description server -l pl.UTF-8
102 Server dla Partimage.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch1 -p1
108 %patch2 -p1
109
110 %build
111 cp -f /usr/share/automake/config.sub .
112 rm -f po/stamp-po
113 %configure \
114         --disable-silent-rules \
115         --enable-pam \
116         --enable-ssl
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{partimaged,pam.d},/etc/rc.d/init.d,/etc/sysconfig,/var/spool/partimage}
122
123 %{__make} -C src install \
124         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %{__make} -C po install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 cat > $RPM_BUILD_ROOT%{_sysconfdir}/partimaged/partimagedusers << EOF
131 #note, '#' intruduces comments
132 #add only users allowed to connect to partimaged
133 # (only one login per line)
134
135 #joe # user 'joe' is allowed to connect to partimaged
136 EOF
137
138 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/partimaged
139 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/partimaged
140 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/partimaged
141 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/partimaged/partimaged.cnf
142
143 touch $RPM_BUILD_ROOT%{_sysconfdir}/partimaged/partimaged.{csr,cert,key}
144
145 %find_lang %{name}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %pre server
151 %groupadd -P %{name}-server -g 98 partimag
152 %useradd -P %{name}-server -u 98 -d %{_sysconfdir}/partimaged -s /bin/false -c "Partimage server" -g partimag partimag
153
154 %post server
155 /sbin/chkconfig --add partimaged
156 if [ ! -s /etc/partimaged/partimaged.key -o ! -s /etc/partimaged/partimaged.cert ]; then
157         echo "Run \"/etc/rc.d/init.d/partimaged init\" to create self-signed SSL certificate." >&2
158 fi
159
160 if [ -f /var/lock/subsys/partimaged ]; then
161         /etc/rc.d/init.d/partimaged restart >&2
162 else
163         echo "Run \"/etc/rc.d/init.d/partimaged start\" to start partimage server." >&2
164 fi
165
166 echo
167
168 %preun server
169 if [ "$1" = "0" ]; then
170         if [ -f /var/lock/subsys/partimaged ]; then
171                 /etc/rc.d/init.d/partimaged stop >&2
172         fi
173         /sbin/chkconfig --del partimaged
174 fi
175
176 %postun server
177 if [ "$1" = "0" ]; then
178         %userremove partimag
179         %groupremove partimag
180 fi
181
182 %files -f %{name}.lang
183 %defattr(644,root,root,755)
184 %doc AUTHORS ChangeLog README* THANKS BUGS
185 %attr(755,root,root) %{_sbindir}/partimage
186
187 %files server
188 %defattr(644,root,root,755)
189 %doc README.partimaged
190 %attr(755,root,root) %{_sbindir}/partimaged
191 %attr(754,root,root) /etc/rc.d/init.d/partimaged
192 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/partimaged
193 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/partimaged
194 %dir %{_sysconfdir}/partimaged
195 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/partimaged/partimaged.cnf
196 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/partimaged/partimaged.csr
197 %attr(600,partimag,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/partimaged/partimaged.key
198 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/partimaged/partimaged.cert
199 %attr(600,partimag,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/partimaged/partimagedusers
200 %attr(700,partimag,root) %dir /var/spool/partimage
This page took 0.049364 seconds and 3 git commands to generate.