]> git.pld-linux.org Git - packages/parallel.git/blob - parallel.spec
073d300c2542041e4866df095314d5233bec4ccd
[packages/parallel.git] / parallel.spec
1 Summary:        Shell tool for executing jobs in parallel
2 Name:           parallel
3 Version:        20201022
4 Release:        1
5 License:        GPL v3+
6 Group:          Applications/System
7 Source0:        https://ftp.gnu.org/gnu/parallel/%{name}-%{version}.tar.bz2
8 # Source0-md5:  03899475967ff4ca529e3f998fbc4932
9 URL:            https://www.gnu.org/software/parallel/
10 BuildRequires:  perl-tools-pod
11 BuildRequires:  rpm-perlprov
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 GNU Parallel is a shell tool for executing jobs in parallel using one
17 or more machines. A job is typically a single command or a small
18 script that has to be run for each of the lines in the input. The
19 typical input is a list of files, a list of hosts, a list of users, or
20 a list of tables.
21
22 If you use xargs today you will find GNU Parallel very easy to use. If
23 you write loops in shell, you will find GNU Parallel may be able to
24 replace most of the loops and make them run faster by running jobs in
25 parallel. If you use ppss or pexec you will find GNU Parallel will
26 often make the command easier to read.
27
28 GNU Parallel also makes sure output from the commands is the same
29 output as you would get had you run the commands sequentially. This
30 makes it possible to use output from GNU Parallel as input for other
31 programs.
32
33 GNU Parallel is command-line-compatible with moreutils' parallel, but
34 offers additional features.
35
36 %package -n env_parallel
37 Summary:        env_parallel
38 Group:          Applications/System
39 Requires:       %{name} = %{version}-%{release}
40
41 %description -n env_parallel
42 env_parallel is a shell function that exports the current environment
43 to GNU parallel.
44
45 %prep
46 %setup -q
47
48 %{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' src/{parallel,sem}
49 %{__sed} -i -e '1{\@^#!@d}' src/env_parallel.*
50 %{__sed} -i -e '1s,^#!/usr/bin/env ,#!/bin/,' src/env_* src/parset
51
52 %build
53 %configure
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_sysconfdir}/parallel
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 mv $RPM_BUILD_ROOT%{_mandir}/man1/{sql,parallel-sql}.1
63 touch $RPM_BUILD_ROOT%{_sysconfdir}/parallel/config
64 rm -rv $RPM_BUILD_ROOT%{_docdir}/parallel
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README NEWS
72 %doc src/parallel.html src/sem.html src/sql.html src/niceload.html
73 %doc src/*.texi
74 %dir %{_sysconfdir}/parallel
75 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/parallel/config
76 %attr(755,root,root) %{_bindir}/niceload
77 %attr(755,root,root) %{_bindir}/parallel
78 %attr(755,root,root) %{_bindir}/parcat
79 %attr(755,root,root) %{_bindir}/parset
80 %attr(755,root,root) %{_bindir}/parsort
81 %attr(755,root,root) %{_bindir}/sem
82 %attr(755,root,root) %{_bindir}/sql
83 %{_mandir}/man1/niceload.1*
84 %{_mandir}/man1/parallel.1*
85 %{_mandir}/man1/parallel-sql.1*
86 %{_mandir}/man1/parcat.1*
87 %{_mandir}/man1/parset.1*
88 %{_mandir}/man1/parsort.1*
89 %{_mandir}/man1/sem.1*
90 %{_mandir}/man7/parallel_alternatives.7*
91 %{_mandir}/man7/parallel_book.7*
92 %{_mandir}/man7/parallel_design.7*
93 %{_mandir}/man7/parallel_tutorial.7*
94
95 %files -n env_parallel
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_bindir}/env_parallel
98 %attr(755,root,root) %{_bindir}/env_parallel.ash
99 %attr(755,root,root) %{_bindir}/env_parallel.bash
100 %attr(755,root,root) %{_bindir}/env_parallel.csh
101 %attr(755,root,root) %{_bindir}/env_parallel.dash
102 %attr(755,root,root) %{_bindir}/env_parallel.fish
103 %attr(755,root,root) %{_bindir}/env_parallel.ksh
104 %attr(755,root,root) %{_bindir}/env_parallel.mksh
105 %attr(755,root,root) %{_bindir}/env_parallel.pdksh
106 %attr(755,root,root) %{_bindir}/env_parallel.sh
107 %attr(755,root,root) %{_bindir}/env_parallel.tcsh
108 %attr(755,root,root) %{_bindir}/env_parallel.zsh
109 %{_mandir}/man1/env_parallel.1*
This page took 0.063999 seconds and 2 git commands to generate.