]> git.pld-linux.org Git - packages/parallel-netcdf.git/blob - parallel-netcdf.spec
e4ca32f083e267e68e4653838fc776629826ef7b
[packages/parallel-netcdf.git] / parallel-netcdf.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        Parallel netCDF (PnetCDF) library
7 Summary(pl.UTF-8):      Biblioteka zrównoleglona netCDF (PnetCDF)
8 Name:           parallel-netcdf
9 Version:        1.12.1
10 Release:        1
11 License:        BSD-like
12 Group:          Libraries
13 #Source0Download: http://cucis.ece.northwestern.edu/projects/PnetCDF/download.html
14 Source0:        http://cucis.ece.northwestern.edu/projects/PnetCDF/Release/pnetcdf-%{version}.tar.gz
15 # Source0-md5:  878192db34e436cbdd869fff3c7bf0c9
16 Patch0:         %{name}-sh.patch
17 URL:            https://trac.mcs.anl.gov/projects/parallel-netcdf
18 BuildRequires:  autoconf >= 2.69
19 BuildRequires:  automake >= 1:1.13
20 BuildRequires:  gcc-fortran
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:2.4.2
23 # mpicc and co.
24 BuildRequires:  mpich-devel
25 BuildRequires:  mpich-fortran-devel
26 BuildRequires:  m4
27 BuildRequires:  rpmbuild(macros) >= 1.752
28 %if %{with apidocs}
29 BuildRequires:  doxygen
30 BuildRequires:  ghostscript
31 BuildRequires:  texlive-latex
32 %endif
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Parallel netCDF (PnetCDF) is a library providing high-performance
37 parallel I/O while still maintaining file-format compatibility with
38 Unidata's NetCDF, specifically the classic CDF 1, 2, and 5 formats.
39 Although NetCDF supports parallel I/O starting from version 4, it is
40 built on top of HDF5 and thus its parallel feature requires files in
41 HDF5 format. PnetCDF is currently the only option for parallel I/O on
42 files in classic formats.
43
44 %description -l pl.UTF-8
45 Parallel netCDF (PnetCDF) to biblioteka zapewniająca bardzo wydajne,
46 równoległe operacje we/wy, zachowując zgodność z formatem plików
47 Unidata NetCDF, w szczególności klasycznych formatach CDF 1, 2, 5.
48 Mimo że NetCDF obsługuje równoległe operacje we/wy począwszy od wersji
49 4, ale w oparciu o HDF5, więc opcja zrównoleglenia wymaga plików w
50 formacie HDF5. PnetCDF to obecnie jedyna możliwość zrównoleglenia
51 we/wy dla plików w klasycznych formatach.
52
53 %package devel
54 Summary:        Header files for PnetCDF library
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki PnetCDF
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       mpich-fortran-devel
59
60 %description devel
61 Header files for PnetCDF library.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe biblioteki PnetCDF.
65
66 %package static
67 Summary:        Static PnetCDF library
68 Summary(pl.UTF-8):      Statyczna biblioteka PnetCDF
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static PnetCDF library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka PnetCDF.
77
78 %package apidocs
79 Summary:        API documentation for PnetCDF library
80 Summary(pl.UTF-8):      Dokumentacja API biblioteki PnetCDF
81 Group:          Documentation
82 %{?noarchpackage}
83
84 %description apidocs
85 API documentation for PnetCDF library.
86
87 %description apidocs -l pl.UTF-8
88 Dokumentacja API biblioteki PnetCDF.
89
90 %prep
91 %setup -q -n pnetcdf-%{version}
92 %patch0 -p1
93
94 %build
95 %{__libtoolize}
96 %{__aclocal} -I m4
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %define gfortran_version        %(gfortran -dumpversion)
101 %if "%{_ver_ge '%{gfortran_version}' '10.0'}" == "1"
102 FFLAGS="%{rpmcflags} -fallow-argument-mismatch"
103 FCFLAGS="%{rpmcflags} -fallow-argument-mismatch"
104 %endif
105 %configure \
106         %{?with_apidocs:--enable-doxygen} \
107         --disable-silent-rules \
108         --enable-shared \
109         %{!?with_static_libs:--disable-static}
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 # .la kept because of MPI dependencies
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS COPYRIGHT CREDITS README RELEASE_NOTES doc/README.{LINUX,consistency,large_files}
129 %attr(755,root,root) %{_bindir}/cdfdiff
130 %attr(755,root,root) %{_bindir}/ncmpidiff
131 %attr(755,root,root) %{_bindir}/ncmpidump
132 %attr(755,root,root) %{_bindir}/ncmpigen
133 %attr(755,root,root) %{_bindir}/ncoffsets
134 %attr(755,root,root) %{_bindir}/ncvalidator
135 %attr(755,root,root) %{_bindir}/pnetcdf_version
136 %attr(755,root,root) %{_libdir}/libpnetcdf.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libpnetcdf.so.4
138 %{_mandir}/man1/cdfdiff.1*
139 %{_mandir}/man1/ncmpidiff.1*
140 %{_mandir}/man1/ncmpidump.1*
141 %{_mandir}/man1/ncmpigen.1*
142 %{_mandir}/man1/ncoffsets.1*
143 %{_mandir}/man1/ncvalidator.1*
144 %{_mandir}/man1/pnetcdf_version.1*
145
146 %files devel
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_bindir}/pnetcdf-config
149 %attr(755,root,root) %{_libdir}/libpnetcdf.so
150 %{_libdir}/libpnetcdf.la
151 %{_includedir}/pnetcdf.h
152 %{_includedir}/pnetcdf
153 %{_includedir}/pnetcdf.inc
154 %{_includedir}/pnetcdf.mod
155 %{_pkgconfigdir}/pnetcdf.pc
156 %{_mandir}/man3/pnetcdf.3*
157 %{_mandir}/man3/pnetcdf_f77.3*
158 %{_mandir}/man3/pnetcdf_f90.3*
159
160 %if %{with static_libs}
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/libpnetcdf.a
164 %endif
165
166 %if %{with apidocs}
167 %files apidocs
168 %defattr(644,root,root,755)
169 %doc doc/pnetcdf-api/pnetcdf-api.pdf
170 %endif
This page took 0.090289 seconds and 2 git commands to generate.