]> git.pld-linux.org Git - packages/pam-pam_mount.git/blob - pam-pam_mount.spec
d0c962612ee677159dc4b1917cf1fe4ff191c6e8
[packages/pam-pam_mount.git] / pam-pam_mount.spec
1 # TODO
2 # - man -l pam_mount.8 | perl -pe 's/.\cH//g' >pam_mount.txt;
3 #   man: invalid option -- 'l'
4 #   man, version 1.6f
5 %define         modulename pam_mount
6 Summary:        A PAM module that can mount remote volumes for a user session
7 Summary(pl.UTF-8):      Moduł PAM, pozwalający montować zdalne zasoby na czas sesji użytkownika
8 Name:           pam-%{modulename}
9 Version:        2.13
10 Release:        1
11 License:        LGPL
12 Group:          Base
13 Source0:        http://downloads.sourceforge.net/pam-mount/%{modulename}-%{version}.tar.xz
14 # Source0-md5:  9f75fc8e84ea9cde619cdd6a62c7de33
15 Source1:        %{name}.tmpfiles
16 URL:            http://pam-mount.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  cryptsetup-luks-devel >= 1.1.2
20 BuildRequires:  glib2-devel
21 BuildRequires:  libHX-devel >= 3.6
22 BuildRequires:  libmount-devel >= 2.20
23 BuildRequires:  libtool
24 BuildRequires:  libxml2-devel
25 BuildRequires:  openssl-devel >= 0.9.8
26 BuildRequires:  pam-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz >= 1:4.999.7
30 BuildRequires:  zlib-devel
31 Obsoletes:      pam_mount
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This module is aimed to environments with SMB (Samba or Windows NT)
36 and/or NCP (Netware or Mars-NWE) servers that Unix users want or need
37 to access, and some users have / every user has private volumes in
38 that servers. The module also supports mounting home directories using
39 loopback encrypted filesystems (see also
40 http://www.tldp.org/HOWTO/Loopback-Encrypted-Filesystem-HOWTO.html).
41  - Every user can access his/her own volumes
42  - The user needs to type the password just once (at login) (*)
43  - The mouting process is transparent to the users
44  - There is no need to keep the login passwords in any additional file
45  - The volumes are unmount upon logout, so it saves system resources,
46    avoiding the need of listing every every possibly useful remote volume
47    in /etc/fstab or in an automount/supermount config file. This is also
48    necessary for securing encrypted filesystems.
49
50 (*) Obviously, the user password in the Unix system and in the remote
51 servers must be the same ;)
52
53 Pam_mount "understands" SMB, NCP, and encrypted loopback volumes, but
54 this can be extended very easily.
55
56 %description -l pl.UTF-8
57 Przeznaczeniem tego modułu są środowiska z protokołem SMB (Samba lub
58 Windows NT) i/lub NCP (Netware lub Mars-NWE), w których użytkownicy
59 chcą lub potrzebują indywidualnych zasobów. Moduł ten wspiera także
60 montowanie katalogów domowych z zaszyfrowanych systemów plików przy
61 użyciu loopbacka (zobacz także:
62 http://www.tldp.org/HOWTO/Loopback-Encrypted-Filesystem-HOWTO.html).
63  - każdy użytkownik ma dostęp do swoich zasobów
64  - użytkownik musi wpisać swoje hasło tylko raz (przy logowaniu) (*)
65  - proces montowania jest niewidzialny dla użytkownika
66  - nie ma potrzeby trzymania hasła i loginu w żadnym dodatkowym pliku
67  - katalogi są odmontowywane podczas wylogowania, co oszczędza zasoby
68    systemowe, zabezpiecza przed koniecznością umieszczenia każdego
69    potrzebnego zdalnego zasobu w /etc/fstab lub w konfiguracji
70    automounta/supermounta. Jest to także konieczne do zabezpieczenia
71    zaszyfrowanych systemów plików.
72
73 (*) Oczywiście hasło na lokalnym i zdalnym systemie musi być
74 identyczne ;)
75
76 pam_mount "rozumie" SMB, NCP oraz zaszyfrowane systemy plików po
77 loopbacku, ale może być rozszerzony w prosty sposób.
78
79 %package -n libcryptmount
80 Summary:        libcryptmount library
81 Summary(pl.UTF-8):      Biblioteka libcryptmount
82 Group:          Libraries
83
84 %description -n libcryptmount
85 libcryptmount library.
86
87 %description -n libcryptmount -l pl.UTF-8
88 Biblioteka libcryptmount
89
90 %package -n libcryptmount-devel
91 Summary:        Header files for libcryptmount library
92 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libcryptmount
93 Group:          Development/Libraries
94 Requires:       libcryptmount = %{version}-%{release}
95
96 %description -n libcryptmount-devel
97 Header files for libcryptmount library.
98
99 %description -n libcryptmount-devel -l pl.UTF-8
100 Pliki nagłówkowe biblioteki libcryptmount.
101
102 %prep
103 %setup -q -n %{modulename}-%{version}
104
105 %build
106 %{__libtoolize}
107 %{__aclocal} -I m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --with-slibdir=/%{_lib} \
113         --disable-static
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT{/etc/security,/sbin,/var/run/pam_mount,%{_bindir}} \
119         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
120
121 %{__make} -j1 install \
122         moduledir=/%{_lib}/security \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 cp -a config/pam_mount.conf.xml $RPM_BUILD_ROOT/etc/security
126 ln -sf /sbin/mount.crypt $RPM_BUILD_ROOT%{_bindir}/mount.crypt
127
128 install %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/pam_mount.conf
129
130 rm $RPM_BUILD_ROOT%{_libdir}/libcryptmount.la
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -n libcryptmount -p /sbin/ldconfig
136 %postun -n libcryptmount -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %attr(755,root,root) /%{_lib}/security/pam_mount.so
141 %config(noreplace) %verify(not md5 mtime size) /etc/security/pam_mount.conf.xml
142 %attr(755,root,root) /sbin/mount.crypt
143 %attr(755,root,root) /sbin/mount.crypt_LUKS
144 %attr(755,root,root) /sbin/mount.crypto_LUKS
145 %attr(755,root,root) /sbin/umount.crypt
146 %attr(755,root,root) /sbin/umount.crypt_LUKS
147 %attr(755,root,root) /sbin/umount.crypto_LUKS
148 %attr(755,root,root) %{_bindir}/mount.crypt
149 %attr(755,root,root) %{_sbindir}/pmt-ehd
150 %attr(755,root,root) %{_sbindir}/pmvarrun
151 %dir /var/run/pam_mount
152 %{systemdtmpfilesdir}/pam_mount.conf
153 %{_mandir}/man5/pam_mount.conf.5*
154 %{_mandir}/man8/mount.crypt.8*
155 %{_mandir}/man8/mount.crypt_LUKS.8*
156 %{_mandir}/man8/mount.crypto_LUKS.8*
157 %{_mandir}/man8/pam_mount.8*
158 %{_mandir}/man8/pmt-ehd.8*
159 %{_mandir}/man8/pmvarrun.8*
160 %{_mandir}/man8/umount.crypt.8*
161 %{_mandir}/man8/umount.crypt_LUKS.8*
162 %{_mandir}/man8/umount.crypto_LUKS.8*
163
164 %files -n libcryptmount
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libcryptmount.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libcryptmount.so.0
168
169 %files -n libcryptmount-devel
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/libcryptmount.so
172 %{_includedir}/libcryptmount.h
173 %{_pkgconfigdir}/libcryptmount.pc
This page took 0.062362 seconds and 2 git commands to generate.