]> git.pld-linux.org Git - packages/pam-pam_mount.git/blob - pam-pam_mount.spec
- up to 2.15
[packages/pam-pam_mount.git] / pam-pam_mount.spec
1 # TODO
2 # - man -l pam_mount.8 | perl -pe 's/.\cH//g' >pam_mount.txt;
3 #   man: invalid option -- 'l'
4 #   man, version 1.6f
5 %define         modulename pam_mount
6 Summary:        A PAM module that can mount remote volumes for a user session
7 Summary(pl.UTF-8):      Moduł PAM, pozwalający montować zdalne zasoby na czas sesji użytkownika
8 Name:           pam-%{modulename}
9 Version:        2.15
10 Release:        1
11 License:        LGPL
12 Group:          Base
13 Source0:        http://downloads.sourceforge.net/pam-mount/%{modulename}-%{version}.tar.xz
14 # Source0-md5:  e3bc28c232b980e468ad2c558a76b473
15 Source1:        %{name}.tmpfiles
16 URL:            http://pam-mount.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  cryptsetup-luks-devel >= 1.1.2
20 BuildRequires:  glib2-devel
21 BuildRequires:  libHX-devel >= 3.12.1
22 BuildRequires:  libmount-devel >= 2.20
23 BuildRequires:  libtool
24 BuildRequires:  libxml2-devel >= 1:2.6
25 BuildRequires:  openssl-devel >= 0.9.8
26 BuildRequires:  pam-devel
27 BuildRequires:  pcre-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz >= 1:4.999.7
31 BuildRequires:  zlib-devel
32 Obsoletes:      pam_mount
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This module is aimed to environments with SMB (Samba or Windows NT)
37 and/or NCP (Netware or Mars-NWE) servers that Unix users want or need
38 to access, and some users have / every user has private volumes in
39 that servers. The module also supports mounting home directories using
40 loopback encrypted filesystems (see also
41 http://www.tldp.org/HOWTO/Loopback-Encrypted-Filesystem-HOWTO.html).
42  - Every user can access his/her own volumes
43  - The user needs to type the password just once (at login) (*)
44  - The mouting process is transparent to the users
45  - There is no need to keep the login passwords in any additional file
46  - The volumes are unmount upon logout, so it saves system resources,
47    avoiding the need of listing every every possibly useful remote volume
48    in /etc/fstab or in an automount/supermount config file. This is also
49    necessary for securing encrypted filesystems.
50
51 (*) Obviously, the user password in the Unix system and in the remote
52 servers must be the same ;)
53
54 Pam_mount "understands" SMB, NCP, and encrypted loopback volumes, but
55 this can be extended very easily.
56
57 %description -l pl.UTF-8
58 Przeznaczeniem tego modułu są środowiska z protokołem SMB (Samba lub
59 Windows NT) i/lub NCP (Netware lub Mars-NWE), w których użytkownicy
60 chcą lub potrzebują indywidualnych zasobów. Moduł ten wspiera także
61 montowanie katalogów domowych z zaszyfrowanych systemów plików przy
62 użyciu loopbacka (zobacz także:
63 http://www.tldp.org/HOWTO/Loopback-Encrypted-Filesystem-HOWTO.html).
64  - każdy użytkownik ma dostęp do swoich zasobów
65  - użytkownik musi wpisać swoje hasło tylko raz (przy logowaniu) (*)
66  - proces montowania jest niewidzialny dla użytkownika
67  - nie ma potrzeby trzymania hasła i loginu w żadnym dodatkowym pliku
68  - katalogi są odmontowywane podczas wylogowania, co oszczędza zasoby
69    systemowe, zabezpiecza przed koniecznością umieszczenia każdego
70    potrzebnego zdalnego zasobu w /etc/fstab lub w konfiguracji
71    automounta/supermounta. Jest to także konieczne do zabezpieczenia
72    zaszyfrowanych systemów plików.
73
74 (*) Oczywiście hasło na lokalnym i zdalnym systemie musi być
75 identyczne ;)
76
77 pam_mount "rozumie" SMB, NCP oraz zaszyfrowane systemy plików po
78 loopbacku, ale może być rozszerzony w prosty sposób.
79
80 %package -n libcryptmount
81 Summary:        libcryptmount library
82 Summary(pl.UTF-8):      Biblioteka libcryptmount
83 Group:          Libraries
84
85 %description -n libcryptmount
86 libcryptmount library.
87
88 %description -n libcryptmount -l pl.UTF-8
89 Biblioteka libcryptmount
90
91 %package -n libcryptmount-devel
92 Summary:        Header files for libcryptmount library
93 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libcryptmount
94 Group:          Development/Libraries
95 Requires:       libcryptmount = %{version}-%{release}
96
97 %description -n libcryptmount-devel
98 Header files for libcryptmount library.
99
100 %description -n libcryptmount-devel -l pl.UTF-8
101 Pliki nagłówkowe biblioteki libcryptmount.
102
103 %prep
104 %setup -q -n %{modulename}-%{version}
105
106 %build
107 %{__libtoolize}
108 %{__aclocal} -I m4
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         --with-slibdir=/%{_lib} \
114         --disable-static
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT{/etc/security,/sbin,/var/run/pam_mount,%{_bindir}} \
120         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
121
122 %{__make} -j1 install \
123         moduledir=/%{_lib}/security \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 cp -a config/pam_mount.conf.xml $RPM_BUILD_ROOT/etc/security
127 ln -sf /sbin/mount.crypt $RPM_BUILD_ROOT%{_bindir}/mount.crypt
128
129 install %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/pam_mount.conf
130
131 rm $RPM_BUILD_ROOT%{_libdir}/libcryptmount.la
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -n libcryptmount -p /sbin/ldconfig
137 %postun -n libcryptmount -p /sbin/ldconfig
138
139 %files
140 %defattr(644,root,root,755)
141 %attr(755,root,root) /%{_lib}/security/pam_mount.so
142 %config(noreplace) %verify(not md5 mtime size) /etc/security/pam_mount.conf.xml
143 %attr(755,root,root) /sbin/mount.crypt
144 %attr(755,root,root) /sbin/mount.crypt_LUKS
145 %attr(755,root,root) /sbin/mount.crypto_LUKS
146 %attr(755,root,root) /sbin/umount.crypt
147 %attr(755,root,root) /sbin/umount.crypt_LUKS
148 %attr(755,root,root) /sbin/umount.crypto_LUKS
149 %attr(755,root,root) %{_bindir}/mount.crypt
150 %attr(755,root,root) %{_sbindir}/pmt-ehd
151 %attr(755,root,root) %{_sbindir}/pmvarrun
152 %dir /var/run/pam_mount
153 %{systemdtmpfilesdir}/pam_mount.conf
154 %{_mandir}/man5/pam_mount.conf.5*
155 %{_mandir}/man8/mount.crypt.8*
156 %{_mandir}/man8/mount.crypt_LUKS.8*
157 %{_mandir}/man8/mount.crypto_LUKS.8*
158 %{_mandir}/man8/pam_mount.8*
159 %{_mandir}/man8/pmt-ehd.8*
160 %{_mandir}/man8/pmvarrun.8*
161 %{_mandir}/man8/umount.crypt.8*
162 %{_mandir}/man8/umount.crypt_LUKS.8*
163 %{_mandir}/man8/umount.crypto_LUKS.8*
164
165 %files -n libcryptmount
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libcryptmount.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libcryptmount.so.0
169
170 %files -n libcryptmount-devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libcryptmount.so
173 %{_includedir}/libcryptmount.h
174 %{_pkgconfigdir}/libcryptmount.pc
This page took 0.064332 seconds and 3 git commands to generate.