]> git.pld-linux.org Git - packages/packer.git/blob - packer.spec
up to 1.5.4; rel 1
[packages/packer.git] / packer.spec
1 Summary:        Tool for creating identical machine images for multiple platforms from a single source configuration
2 Name:           packer
3 Version:        1.5.4
4 Release:        1
5 License:        MPL 2.0
6 Group:          Applications/Emulators
7 Source0:        https://github.com/hashicorp/packer/archive/v%{version}.tar.gz
8 # Source0-md5:  8c11adb7aa529793675a075dc9db40b0
9 URL:            http://www.packer.io/
10 BuildRequires:  bash
11 BuildRequires:  golang >= 1.13
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %define         _enable_debug_packages 0
15 %define         gobuild go build -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n')" -a -v -x
16
17 %description
18 Packer is an open source tool for creating identical machine images
19 for multiple platforms from a single source configuration. Packer is
20 lightweight, runs on every major operating system, and is highly
21 performant, creating machine images for multiple platforms in
22 parallel. Packer does not replace configuration management like Chef
23 or Puppet. In fact, when building images, Packer is able to use tools
24 like Chef or Puppet to install software onto the image.
25
26 A machine image is a single static unit that contains a pre-configured
27 operating system and installed software which is used to quickly
28 create new running machines. Machine image formats change for each
29 platform. Some examples include AMIs for EC2, VMDK/VMX files for
30 VMware, OVF exports for VirtualBox, etc.
31
32 %prep
33 %setup -q
34
35 %build
36 %gobuild -mod=vendor -o %{name}-binary
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT%{_bindir}
41 cp -a %{name}-binary $RPM_BUILD_ROOT%{_bindir}/%{name}
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc README.md CHANGELOG.md LICENSE
49 %attr(755,root,root) %{_bindir}/packer
This page took 0.051355 seconds and 3 git commands to generate.