]> git.pld-linux.org Git - packages/p7zip.git/blob - p7zip.spec
- fix sed usage, STBR
[packages/p7zip.git] / p7zip.spec
1 Summary:        File archiver with highest compression ratio
2 Summary(pl):    Paker plików z najwy¿szym stopniem kompresji
3 Name:           p7zip
4 Version:        4.14.01
5 Release:        1
6 License:        LGPL
7 Group:          Applications/Archiving
8 Source0:        http://dl.sourceforge.net/p7zip/%{name}_%{version}_src.tar.bz2
9 # Source0-md5:  1c67efe94aeafea962cb2f85db2b8d9c
10 Patch0:         %{name}-opt.patch
11 URL:            http://p7zip.sourceforge.net/
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  sed >= 4.0
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 7-Zip is a file archiver with highest compression ratio.
18
19 The main features of 7z format:
20 - Open architecture
21 - High compression ratio
22 - Strong AES-256 encryption
23 - Ability of using any compression, conversion or encryption method
24 - Supporting files with sizes up to 16000000000 GB
25 - Unicode file names
26 - Solid compressing
27 - Archive headers compressing
28
29 %description -l pl
30 7-Zip jest pakerem plików z najwy¿szym stopniem kompresji.
31
32 G³ówne cechy formatu 7z:
33 - otwarta architektura,
34 - wysoki stopieñ kompresji,
35 - silne kodowanie AES-256,
36 - mo¿liwo¶æ u¿ywania dowolnych metod kodowania, kompresji, konwersji,
37 - obs³uga bardzo du¿ych plików (powy¿ej 16000000000 GB),
38 - obs³uga nazw plików w unikodzie,
39 - kompresja upakowana,
40 - kompresja nag³ówków archiwum.
41
42 %package stand-alone
43 Summary:        Stand-alone 7zip executable
44 Summary(pl):    Samodzielny plik wykonywalny 7zip
45 Group:          Applications/Archiving
46
47 %description stand-alone
48 Stand-alone version of 7zip. It handles less archive formats than
49 plugin capable version.
50
51 %description stand-alone -l pl
52 Samodzielna wersja 7zip-a. Obs³uguje mniej formatów archiwów ni¿
53 wersja obs³uguj±ca wtyczki.
54
55 %prep
56 %setup -q -n %{name}_%{version}
57 %patch0 -p1
58
59 # big vs little endian
60 %ifarch ppc
61 cp -f makefile.linux_ppc makefile.machine
62 %else
63 cp -f makefile.linux_x86 makefile.machine
64 %endif
65
66 %{__sed} -i "s@Formats@%{_libdir}/%{name}/&@" \
67         7zip/UI/Common/ArchiverInfo.cpp
68 %{__sed} -i 's,return GetBaseFolderPrefix.*,return TEXT("%{_libdir}/%{name}/Codecs/");,g' \
69         7zip/Archive/Common/CodecsPath.cpp
70
71 %build
72 %{__make} all2 \
73         _CC="%{__cc} %{rpmcflags}" \
74         _CXX="%{__cxx} %{rpmcflags}"
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/{Codecs,Formats}}
79
80 install bin/7z* $RPM_BUILD_ROOT%{_bindir}
81 install bin/Codecs/* $RPM_BUILD_ROOT%{_libdir}/%{name}/Codecs
82 install bin/Formats/* $RPM_BUILD_ROOT%{_libdir}/%{name}/Formats
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc DOCS/{MANUAL,{7zFormat,Methods,history,lzma,readme}.txt} ChangeLog README TODO
90 %attr(755,root,root) %{_bindir}/7z
91 %attr(755,root,root) %{_bindir}/7zCon.sfx
92 %dir %{_libdir}/%{name}
93 %dir %{_libdir}/%{name}/Codecs
94 %attr(755,root,root) %{_libdir}/%{name}/Codecs/*
95 %dir %{_libdir}/%{name}/Formats
96 %attr(755,root,root) %{_libdir}/%{name}/Formats/*
97
98 %files stand-alone
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_bindir}/7za
This page took 0.063777 seconds and 4 git commands to generate.