]> git.pld-linux.org Git - packages/owncloudclient.git/blob - owncloudclient.spec
- main build works
[packages/owncloudclient.git] / owncloudclient.spec
1
2 Summary:        The ownCloud client
3 Name:           owncloudclient
4 Version:        2.1.1
5 Release:        0.2
6 License:        GPL-2.0+
7 Group:          X11/Applications
8 URL:            https://www.owncloud.com
9 Source0:        https://download.owncloud.com/desktop/stable/%{name}-%{version}.tar.xz
10 # Source0-md5:  63a971158201a8dffe96a02c54b86819
11 #Source1:       owncloud.sh
12 #Source2:       owncloudcmd.sh
13 BuildRequires:  cmake >= 2.8.11
14 #BuildRequires: qt4-devel >= 4.7
15 #BuildRequires: qtwebkit-devel >= 2.2
16 BuildRequires:  desktop-file-utils
17 BuildRequires:  openssl-devel
18 BuildRequires:  python-Sphinx
19 BuildRequires:  sphinx-pdg
20 BuildRequires:  texlive-latex-ams
21 BuildRequires:  QtKeychain-devel
22 Suggests:       %{name}-nautilus
23 Suggests:       %{name}-nemo
24 Requires:       %{name}-l10n
25 Requires:       libowncloudsync0 = %{version}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The ownCloud sync client - github.com/owncloud/client
30
31 ownCloud client enables you to connect to your private ownCloud
32 Server. With it you can create folders in your home directory, and
33 keep the contents of those folders synced with your ownCloud server.
34 Simply copy a file into the directory and the ownCloud Client does the
35 rest.
36
37 ownCloud gives your employees anytime, anywhere access to the files
38 they need to get the job done, whether through this desktop
39 application, our mobile apps, the web interface, or other WebDAV
40 clients. With it, your employees can easily view and share documents
41 and information critical to the business, in a secure, flexible and
42 controlled architecture. You can easily extend ownCloud with plug-ins
43 from the community, or that you build yourself to meet the
44 requirements of your infrastructure and business.
45
46 %package -n %{name}-doc
47 Summary:        Documentation for ownCloud
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Obsoletes:      opt-owncloud-client-doc
51
52 %description -n %{name}-doc
53 Documentation about the ownCloud desktop application.
54
55 %package -n %{name}-l10n
56 Summary:        Localization for ownCloud
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Obsoletes:      opt-owncloud-client-l10n
60
61 %description -n %{name}-l10n
62 Localization files for the ownCloud desktop application.
63
64 %package -n libowncloudsync0
65 Summary:        The ownCloud sync library
66 Group:          Development/Libraries
67
68 %description -n libowncloudsync0
69 The ownCloud sync library.
70
71 %package -n libowncloudsync-devel
72 Summary:        Development files for the ownCloud sync library
73 Group:          Development/Libraries
74 Requires:       libowncloudsync0 = %{version}
75
76 %description -n libowncloudsync-devel
77 Development files for the ownCloud sync library.
78
79 %package -n %{name}-nautilus
80 Summary:        Nautilus overlay icons
81 Group:          Productivity/Networking/Other
82 Requires:       nautilus
83 Requires:       nautilus-python
84 Requires:       python-nautilus
85 Requires:       %{name} = %{version}-%{release}
86
87 %description -n %{name}-nautilus
88 This package provides overlay icons to visualize the sync state in the
89 nautilus file manager.
90
91 %package -n %{name}-nemo
92 Summary:        Nemo overlay icons
93 Group:          Productivity/Networking/Other
94 Requires:       nemo
95 Requires:       nemo-python
96 Requires:       python-nemo
97 Requires:       %{name} = %{version}-%{release}
98
99 %description -n %{name}-nemo
100 This package provides overlay icons to visualize the sync state in the
101 nemo file manager.
102
103 %prep
104 %setup -q
105 # autostart_use_wrapper.diff
106 #patch1 -p1
107
108 %build
109 install -d build
110 cd build
111 %cmake \
112         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
113         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
114         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
115         -DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qtkeychain \
116         -DQTKEYCHAIN_LIBRARY=/usr/%{_lib}/libqtkeychain.so \
117         ../
118 %{__make}
119
120 # documentation here?
121 if [ -e conf.py ];
122 then
123   # for old cmake versions we need to move the conf.py.
124   mv conf.py doc/
125 fi
126
127 %{__make} doc
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134   install -d ${RPM_BUILD_ROOT}%{_docdir}/%{name}
135   mv ${RPM_BUILD_ROOT}%{_docdir}/client/* ${RPM_BUILD_ROOT}%{_docdir}/%{name}
136   rmdir ${RPM_BUILD_ROOT}%{_docdir}/client
137   rm ${RPM_BUILD_ROOT}%{_docdir}/%{name}/html/unthemed/.buildinfo
138   mv ${RPM_BUILD_ROOT}%{_docdir}/%{name}/html/unthemed/* ${RPM_BUILD_ROOT}%{_docdir}/%{name}/html/
139   rmdir ${RPM_BUILD_ROOT}%{_docdir}/%{name}/html/unthemed
140
141   install -d ${RPM_BUILD_ROOT}%{_mandir}man1
142   mv ${RPM_BUILD_ROOT}%{_mandir}/man1/{owncloud.1,owncloud.1}
143   mv ${RPM_BUILD_ROOT}%{_mandir}/man1/{owncloudcmd.1,owncloudcmd.1}
144
145 %define extdir ${RPM_BUILD_ROOT}%{_datadir}/nautilus-python/extensions
146 test -f %{extdir}/ownCloud.py  && mv %{extdir}/ownCloud.py  %{extdir}/owncloud.py  || true
147 test -f %{extdir}/ownCloud.pyo && mv %{extdir}/ownCloud.pyo %{extdir}/owncloud.pyo || true
148 test -f %{extdir}/ownCloud.pyc && mv %{extdir}/ownCloud.pyc %{extdir}/owncloud.pyc || true
149
150 install -d ${RPM_BUILD_ROOT}/%{optdir}/bin
151 mv ${RPM_BUILD_ROOT}/%{_bindir}/owncloud* ${RPM_BUILD_ROOT}/%{optdir}/bin/
152
153 cp -p %{SOURCE1} ${RPM_BUILD_ROOT}%{_bindir}/owncloud
154 cp -p %{SOURCE2} ${RPM_BUILD_ROOT}%{_bindir}/owncloudcmd
155
156 %check
157 ## use exit 0 instead of exit 1 to turn this into warnings:
158 if [ "%{name}" != "testpilotcloud-client" ]; then
159   if [ "%{prerelease}" == "" ]; then
160     expr match '%{distribution}' '.*:community:\(testing\|nightly\)' && { echo "Error: Need a prerelease here, not %{version}"; exit 1; }
161   else
162     expr match '%{distribution}' '.*:community:desktop' && { echo "Error: Must not have a prerelease here, not %{version}"; exit 1; }
163   fi
164 fi
165
166 %post
167 /bin/%update_icon_cache_post hicolor &>/dev/null || :
168
169 %postun
170 if [ $1 -eq 0 ] ; then
171     /bin/%update_icon_cache_post hicolor &>/dev/null
172     %{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
173 fi
174
175 %posttrans
176 %{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
177
178 %post -n libowncloudsync0
179 /sbin/ldconfig
180
181 %postun -n libowncloudsync0
182 /sbin/ldconfig
183
184 %files
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_bindir}/owncloud
187 %attr(755,root,root) %{_bindir}/owncloudcmd
188 %{optdir}/bin/owncloud
189 %{optdir}/bin/owncloudcmd
190
191 %{_desktopdir}/owncloud.desktop
192 %{_iconsdir}/hicolor
193 %{_mandir}/man1/owncloud*
194
195 %{_iconsdir}/hicolor
196 %{_desktopdir}/owncloud.desktop
197 %attr(755,root,root) %{_bindir}/owncloud
198 %attr(755,root,root) %{_bindir}/owncloudcmd
199 %config %{_sysconfdir}/ownCloud
200 %dir %{_sysconfdir}
201
202 %files -n %{name}-doc
203 %defattr(644,root,root,755)
204 %doc README.md COPYING
205 %doc %{_docdir}/%{name}
206
207 %files -n %{name}-l10n
208 %defattr(644,root,root,755)
209 %{_datadir}/owncloud
210
211 %files -n libowncloudsync0
212 %defattr(644,root,root,755)
213 %{_libdir}/libowncloudsync.so.*
214 %{_libdir}/owncloud/libocsync.so.*
215 %dir %{_libdir}/owncloud
216
217 %files -n libowncloudsync-devel
218 %defattr(644,root,root,755)
219 %{_libdir}/libowncloudsync.so
220 %{_libdir}/owncloud/libocsync.so
221 %{_includedir}/owncloudsync/
222
223 %files -n %{name}-nautilus
224 %defattr(644,root,root,755)
225 # Fedora also has *.pyc and *.pyo files here.
226 %{_datadir}/nautilus-python/extensions/syncstate.py*
227 %dir %{_datadir}/nautilus-python
228 %dir %{_datadir}/nautilus-python/extensions/
229
230 %files -n %{name}-nemo
231 %defattr(644,root,root,755)
232 # Fedora also has *.pyc and *.pyo files here.
233 %{_datadir}/nemo-python/extensions/syncstate.py*
234 %dir %{_datadir}/nemo-python
235 %dir %{_datadir}/nemo-python/extensions/
236
237 %clean
238 rm -rf $RPM_BUILD_ROOT
This page took 0.115112 seconds and 4 git commands to generate.