]> git.pld-linux.org Git - packages/owncloudclient.git/blob - owncloudclient.spec
obsolete also mirall-libs
[packages/owncloudclient.git] / owncloudclient.spec
1 #
2 # Conditional build:
3 %bcond_without  nautilus        # build Nautilus extension
4 %bcond_without  doc             # build docs
5 %bcond_without  gui             # build only libraries
6
7 %if %{without gui}
8 %undefine       with_nautilus
9 %undefine       with_doc
10 %endif
11
12 Summary:        The ownCloud client
13 Name:           owncloudclient
14 Version:        2.1.1
15 Release:        0.12
16 License:        GPL v2+
17 Group:          X11/Applications
18 Source0:        https://download.owncloud.com/desktop/stable/%{name}-%{version}.tar.xz
19 # Source0-md5:  63a971158201a8dffe96a02c54b86819
20 URL:            https://www.owncloud.com/
21 BuildRequires:  QtCore-devel
22 BuildRequires:  QtDBus-devel
23 BuildRequires:  QtGui-devel
24 BuildRequires:  QtKeychain-devel
25 BuildRequires:  QtNetwork-devel
26 BuildRequires:  QtSql-devel
27 BuildRequires:  QtWebKit-devel
28 BuildRequires:  QtXmlPatterns-devel
29 BuildRequires:  cmake >= 2.8.11
30 BuildRequires:  kf5-ki18n-devel
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  openssl-devel
33 BuildRequires:  pkgconfig
34 BuildRequires:  python
35 BuildRequires:  python-Sphinx
36 BuildRequires:  python-modules
37 BuildRequires:  qt4-linguist
38 BuildRequires:  rpm-pythonprov
39 BuildRequires:  sphinx-pdg
40 BuildRequires:  sqlite3-devel
41 BuildRequires:  tar >= 1:1.22
42 %if %{with doc}
43 BuildRequires:  texlive-latex-ams
44 %endif
45 BuildRequires:  xz
46 Requires:       %{name}-libs = %{version}-%{release}
47 Requires:       Qt5Gui-platform-xcb
48 Suggests:       %{name}-nautilus
49 Suggests:       %{name}-nemo
50 Obsoletes:      mirall < 1.8
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 The ownCloud sync client - github.com/owncloud/client
55
56 ownCloud client enables you to connect to your private ownCloud
57 Server. With it you can create folders in your home directory, and
58 keep the contents of those folders synced with your ownCloud server.
59 Simply copy a file into the directory and the ownCloud Client does the
60 rest.
61
62 ownCloud gives your employees anytime, anywhere access to the files
63 they need to get the job done, whether through this desktop
64 application, our mobile apps, the web interface, or other WebDAV
65 clients. With it, your employees can easily view and share documents
66 and information critical to the business, in a secure, flexible and
67 controlled architecture. You can easily extend ownCloud with plug-ins
68 from the community, or that you build yourself to meet the
69 requirements of your infrastructure and business.
70
71 %package libs
72 Summary:        Shared ownCloud client libraries
73 Group:          Libraries
74 Obsoletes:      mirall-libs < 1.8
75
76 %description libs
77 Shared ownCloud client libraries.
78
79 %package devel
80 Summary:        Header files for %{name} library
81 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
82 Group:          Development/Libraries
83 Requires:       %{name}-libs = %{version}-%{release}
84
85 %description devel
86 Header files for %{name} library.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe biblioteki %{name}.
90
91 %package nautilus
92 Summary:        Nautilus overlay icons
93 Group:          Applications
94 Requires:       %{name} = %{version}-%{release}
95 Requires:       nautilus-python
96
97 %description nautilus
98 This package provides overlay icons to visualize the sync state in the
99 Nautilus file manager.
100
101 %prep
102 %setup -q
103
104 %build
105 install -d build
106 cd build
107 %cmake \
108         -DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qtkeychain \
109         -DQTKEYCHAIN_LIBRARY=/usr/%{_lib}/libqtkeychain.so \
110         -DQT_LRELEASE_EXECUTABLE=/usr/bin/lrelease-qt4 \
111         %{!?with_gui:-DBUILD_LIBRARIES_ONLY=ON} \
112         ..
113 %{__make}
114
115 %if %{with doc}
116 # documentation here?
117 if [ -e conf.py ]; then
118         # for old cmake versions we need to move the conf.py.
119         mv conf.py doc/
120 fi
121 %{__make} doc
122 %endif
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 %{__make} -C build install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 %if %{with nautilus}
130 # nemo not in pld
131 %{__rm} $RPM_BUILD_ROOT%{_datadir}/nemo-python/extensions/syncstate.py*
132 %endif
133
134 %if %{with doc}
135 mv $RPM_BUILD_ROOT%{_docdir}/html ${RPM_BUILD_ROOT}%{_docdir}/%{name}
136 mv $RPM_BUILD_ROOT%{_docdir}/latex ${RPM_BUILD_ROOT}%{_docdir}/%{name}
137 rm $RPM_BUILD_ROOT%{_docdir}/%{name}/unthemed/.buildinfo
138 %endif
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post
144 %update_icon_cache_post hicolor
145
146 %postun
147 if [ $1 -eq 0 ] ; then
148         %update_icon_cache_post hicolor
149 fi
150
151 %post   libs -p /sbin/ldconfig
152 %postun libs -p /sbin/ldconfig
153
154 %if %{with gui}
155 %files
156 %defattr(644,root,root,755)
157 %doc README.md COPYING
158 %dir %{_sysconfdir}/ownCloud
159 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ownCloud/*
160 %attr(755,root,root) %{_bindir}/owncloud
161 %attr(755,root,root) %{_bindir}/owncloudcmd
162 %{_desktopdir}/owncloud.desktop
163 %{_iconsdir}/*/*/apps/*.png
164 %{_datadir}/owncloud
165 %dir %{_libdir}/owncloud
166 %if %{with doc}
167 %doc %{_docdir}/%{name}
168 %{_mandir}/man1/owncloud*
169 %endif
170 %endif
171
172 %files libs
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_libdir}/libowncloudsync.so.*.*.*
175 %ghost %{_libdir}/libowncloudsync.so.0
176 %attr(755,root,root) %{_libdir}/owncloud/libocsync.so.*.*.*
177 %ghost %{_libdir}/owncloud/libocsync.so.0
178
179 %files devel
180 %defattr(644,root,root,755)
181 %{_includedir}/owncloudsync
182 %{_libdir}/libowncloudsync.so
183 %{_libdir}/owncloud/libocsync.so
184
185 %if %{with nautilus}
186 %files nautilus
187 %defattr(644,root,root,755)
188 %{_datadir}/nautilus-python/extensions/syncstate.py*
189 %endif
This page took 0.067257 seconds and 4 git commands to generate.