]> git.pld-linux.org Git - packages/owncloudclient.git/blob - owncloudclient.spec
move ocsync lib to standard dir
[packages/owncloudclient.git] / owncloudclient.spec
1 #
2 # Conditional build:
3 %bcond_without  nautilus        # build Nautilus extension
4 %bcond_without  doc             # build docs
5 %bcond_without  gui             # build only libraries
6
7 %if %{without gui}
8 %undefine       with_nautilus
9 %undefine       with_doc
10 %endif
11
12 Summary:        The ownCloud client
13 Name:           owncloudclient
14 Version:        2.1.1
15 Release:        0.14
16 License:        GPL v2+
17 Group:          X11/Applications
18 Source0:        https://download.owncloud.com/desktop/stable/%{name}-%{version}.tar.xz
19 # Source0-md5:  63a971158201a8dffe96a02c54b86819
20 URL:            https://www.owncloud.com/
21 BuildRequires:  QtCore-devel
22 BuildRequires:  QtDBus-devel
23 BuildRequires:  QtGui-devel
24 BuildRequires:  QtKeychain-devel
25 BuildRequires:  QtNetwork-devel
26 BuildRequires:  QtSql-devel
27 BuildRequires:  QtWebKit-devel
28 BuildRequires:  QtXmlPatterns-devel
29 BuildRequires:  cmake >= 2.8.11
30 BuildRequires:  kf5-ki18n-devel
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  openssl-devel
33 BuildRequires:  pkgconfig
34 BuildRequires:  python
35 BuildRequires:  python-Sphinx
36 BuildRequires:  python-modules
37 BuildRequires:  qt4-linguist
38 BuildRequires:  rpm-pythonprov
39 BuildRequires:  rpmbuild(macros) >= 1.596
40 BuildRequires:  sphinx-pdg
41 BuildRequires:  sqlite3-devel
42 BuildRequires:  tar >= 1:1.22
43 BuildRequires:  xz
44 %if %{with doc}
45 BuildRequires:  texlive-latex-ams
46 %endif
47 Requires:       %{name}-libs = %{version}-%{release}
48 Requires:       Qt5Gui-platform-xcb
49 Requires:       desktop-file-utils
50 Requires:       gtk-update-icon-cache
51 Requires:       hicolor-icon-theme
52 Suggests:       %{name}-nautilus
53 Suggests:       %{name}-nemo
54 Obsoletes:      mirall < 1.8
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 The ownCloud sync client - github.com/owncloud/client
59
60 ownCloud client enables you to connect to your private ownCloud
61 Server. With it you can create folders in your home directory, and
62 keep the contents of those folders synced with your ownCloud server.
63 Simply copy a file into the directory and the ownCloud Client does the
64 rest.
65
66 ownCloud gives your employees anytime, anywhere access to the files
67 they need to get the job done, whether through this desktop
68 application, our mobile apps, the web interface, or other WebDAV
69 clients. With it, your employees can easily view and share documents
70 and information critical to the business, in a secure, flexible and
71 controlled architecture. You can easily extend ownCloud with plug-ins
72 from the community, or that you build yourself to meet the
73 requirements of your infrastructure and business.
74
75 %package libs
76 Summary:        Shared ownCloud client libraries
77 Group:          Libraries
78 Obsoletes:      mirall-libs < 1.8
79
80 %description libs
81 Shared ownCloud client libraries.
82
83 %package devel
84 Summary:        Header files for %{name} library
85 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
86 Group:          Development/Libraries
87 Requires:       %{name}-libs = %{version}-%{release}
88
89 %description devel
90 Header files for %{name} library.
91
92 %description devel -l pl.UTF-8
93 Pliki nagłówkowe biblioteki %{name}.
94
95 %package nautilus
96 Summary:        Nautilus overlay icons
97 Group:          Applications
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       nautilus-python
100
101 %description nautilus
102 This package provides overlay icons to visualize the sync state in the
103 Nautilus file manager.
104
105 %prep
106 %setup -q
107
108 %build
109 install -d build
110 cd build
111 %cmake \
112         -DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qtkeychain \
113         -DQTKEYCHAIN_LIBRARY=/usr/%{_lib}/libqtkeychain.so \
114         -DQT_LRELEASE_EXECUTABLE=/usr/bin/lrelease-qt4 \
115         %{!?with_gui:-DBUILD_LIBRARIES_ONLY=ON} \
116         ..
117 %{__make}
118
119 %if %{with doc}
120 # documentation here?
121 if [ -e conf.py ]; then
122         # for old cmake versions we need to move the conf.py.
123         mv conf.py doc/
124 fi
125 %{__make} doc
126 %endif
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 %{__make} -C build install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 # owncloud client links without rpath
134 mv $RPM_BUILD_ROOT%{_libdir}/owncloud/libocsync.so* $RPM_BUILD_ROOT%{_libdir}
135
136 %if %{with nautilus}
137 # nemo not in pld
138 %{__rm} $RPM_BUILD_ROOT%{_datadir}/nemo-python/extensions/syncstate.py*
139 %endif
140
141 %if %{with doc}
142 mv $RPM_BUILD_ROOT%{_docdir}/html ${RPM_BUILD_ROOT}%{_docdir}/%{name}
143 mv $RPM_BUILD_ROOT%{_docdir}/latex ${RPM_BUILD_ROOT}%{_docdir}/%{name}
144 rm $RPM_BUILD_ROOT%{_docdir}/%{name}/unthemed/.buildinfo
145 %endif
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post
151 %update_desktop_database
152 %update_icon_cache hicolor
153
154 %postun
155 %update_desktop_database
156 %update_icon_cache hicolor
157
158 %post   libs -p /sbin/ldconfig
159 %postun libs -p /sbin/ldconfig
160
161 %if %{with gui}
162 %files
163 %defattr(644,root,root,755)
164 %doc README.md COPYING
165 %dir %{_sysconfdir}/ownCloud
166 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ownCloud/*
167 %attr(755,root,root) %{_bindir}/owncloud
168 %attr(755,root,root) %{_bindir}/owncloudcmd
169 %{_desktopdir}/owncloud.desktop
170 %{_iconsdir}/*/*/apps/*.png
171 %{_datadir}/owncloud
172 %dir %{_libdir}/owncloud
173 %if %{with doc}
174 %doc %{_docdir}/%{name}
175 %{_mandir}/man1/owncloud*
176 %endif
177 %endif
178
179 %files libs
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/libowncloudsync.so.*.*.*
182 %ghost %{_libdir}/libowncloudsync.so.0
183 %attr(755,root,root) %{_libdir}/libocsync.so.*.*.*
184 %ghost %{_libdir}/libocsync.so.0
185
186 %files devel
187 %defattr(644,root,root,755)
188 %{_includedir}/owncloudsync
189 %{_libdir}/libowncloudsync.so
190 %{_libdir}/libocsync.so
191
192 %if %{with nautilus}
193 %files nautilus
194 %defattr(644,root,root,755)
195 %{_datadir}/nautilus-python/extensions/syncstate.py*
196 %endif
This page took 0.042023 seconds and 4 git commands to generate.