]> git.pld-linux.org Git - packages/owncloudclient.git/blob - owncloudclient.spec
nautilus subpackage; drop nemo
[packages/owncloudclient.git] / owncloudclient.spec
1 #
2 # Conditional build:
3 %bcond_without  nautilus                # build Nautilus extension
4
5 Summary:        The ownCloud client
6 Name:           owncloudclient
7 Version:        2.1.1
8 Release:        0.9
9 License:        GPL v2+
10 Group:          X11/Applications
11 Source0:        https://download.owncloud.com/desktop/stable/%{name}-%{version}.tar.xz
12 # Source0-md5:  63a971158201a8dffe96a02c54b86819
13 URL:            https://www.owncloud.com/
14 BuildRequires:  QtCore-devel
15 BuildRequires:  QtDBus-devel
16 BuildRequires:  QtGui-devel
17 BuildRequires:  QtKeychain-devel
18 BuildRequires:  QtNetwork-devel
19 BuildRequires:  QtSql-devel
20 BuildRequires:  QtWebKit-devel
21 BuildRequires:  QtXmlPatterns-devel
22 BuildRequires:  cmake >= 2.8.11
23 BuildRequires:  desktop-file-utils
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  openssl-devel
26 BuildRequires:  pkgconfig
27 BuildRequires:  python-Sphinx
28 BuildRequires:  sphinx-pdg
29 BuildRequires:  sqlite3-devel
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  texlive-latex-ams
32 BuildRequires:  xz
33 Requires:       %{name}-libs = %{version}-%{release}
34 Requires:       Qt5Gui-platform-xcb
35 Suggests:       %{name}-nautilus
36 Suggests:       %{name}-nemo
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 The ownCloud sync client - github.com/owncloud/client
41
42 ownCloud client enables you to connect to your private ownCloud
43 Server. With it you can create folders in your home directory, and
44 keep the contents of those folders synced with your ownCloud server.
45 Simply copy a file into the directory and the ownCloud Client does the
46 rest.
47
48 ownCloud gives your employees anytime, anywhere access to the files
49 they need to get the job done, whether through this desktop
50 application, our mobile apps, the web interface, or other WebDAV
51 clients. With it, your employees can easily view and share documents
52 and information critical to the business, in a secure, flexible and
53 controlled architecture. You can easily extend ownCloud with plug-ins
54 from the community, or that you build yourself to meet the
55 requirements of your infrastructure and business.
56
57 %package libs
58 Summary:        Shared ownCloud client libraries
59 Group:          Libraries
60
61 %description libs
62 Shared ownCloud client libraries.
63
64 %package devel
65 Summary:        Header files for %{name} library
66 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
67 Group:          Development/Libraries
68 Requires:       %{name}-libs = %{version}-%{release}
69
70 %description devel
71 Header files for %{name} library.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe biblioteki %{name}.
75
76 %package nautilus
77 Summary:        A Nautilus extension for %{name}
78 Group:          Applications
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       nautilus-python
81
82 %description nautilus
83 A %{name} extension to Nautilus file browser.
84
85 %prep
86 %setup -q
87
88 %build
89 install -d build
90 cd build
91 %cmake \
92         -DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qtkeychain \
93         -DQTKEYCHAIN_LIBRARY=/usr/%{_lib}/libqtkeychain.so \
94         ..
95 %{__make}
96
97 # documentation here?
98 if [ -e conf.py ]; then
99         # for old cmake versions we need to move the conf.py.
100         mv conf.py doc/
101 fi
102
103 %{__make} doc
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 %{__make} -C build install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 # nemo not in pld
111 %{__rm} $RPM_BUILD_ROOT%{_datadir}/nemo-python/extensions/syncstate.py*
112
113 mv $RPM_BUILD_ROOT%{_docdir}/html ${RPM_BUILD_ROOT}%{_docdir}/%{name}
114 mv $RPM_BUILD_ROOT%{_docdir}/latex ${RPM_BUILD_ROOT}%{_docdir}/%{name}
115 rm $RPM_BUILD_ROOT%{_docdir}/%{name}/unthemed/.buildinfo
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 %update_icon_cache_post hicolor
122
123 %postun
124 if [ $1 -eq 0 ] ; then
125         %update_icon_cache_post hicolor
126 fi
127
128 %post   libs -p /sbin/ldconfig
129 %postun libs -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc README.md COPYING
134 %doc %{_docdir}/%{name}
135 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ownCloud/*
136 %attr(755,root,root) %{_bindir}/owncloud
137 %attr(755,root,root) %{_bindir}/owncloudcmd
138 %{_desktopdir}/owncloud.desktop
139 %{_iconsdir}/*/*/apps/*.png
140 %{_datadir}/owncloud
141 #%{_libdir}/owncloud/libocsync.so.*
142 %dir %{_libdir}/owncloud
143 %{_mandir}/man1/owncloud*
144
145 %files libs
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libowncloudsync.so.*.*.*
148 %ghost %{_libdir}/libowncloudsync.so.0
149 %attr(755,root,root) %{_libdir}/owncloud/libocsync.so.*.*.*
150 %ghost %{_libdir}/owncloud/libocsync.so.0
151
152 %files devel
153 %defattr(644,root,root,755)
154 %{_includedir}/owncloudsync
155 %{_libdir}/libowncloudsync.so
156 %{_libdir}/owncloud/libocsync.so
157
158 %if %{with nautilus}
159 %files nautilus
160 %defattr(644,root,root,755)
161 %{_datadir}/nautilus-python/extensions/syncstate.py*
162 %endif
This page took 0.042513 seconds and 4 git commands to generate.